uva—benefit


  Benefit 
Recently Yaghoub is playing a new trick to sell some more. When somebody gives him A Tomans, he who never has appropriate changes, asks for B Tomans such that lowest common multiple of A and B equals to C and he will pay back a round bill. Or otherwise take some snack instead of the remaining of his money. He believes that finding such a number is hard enough that dissuades students from paying that.

You should write a program that help poor students giving the appropriate amount of money to Yaghoub. Of course if there are several answers you go for students' benefit which is the lowest of them.

Input 

The first line begin with an integer T ( T$ \le$100000), the number of tests. Each test that comes in a separate line contains two integers A and C ( 1$ \le$A, C$ \le$107).

Output 

Print the lowest integer B such that LCM(A, B) = C in a single line. If no such integer exists, print " NO SOLUTION" instead. (Quotes for clarity)

Sample Input 

3
2 6
32 1760
7 16

Sample Output 

3
55
NO SOLUTION
題意:給出A,C,A是其中一個數,C是lcm,求另一個數B,即A和B的最小公倍數是C。沒有輸出“NO SOLUTION”

解析:先判斷有沒有解,若是C%A!=0,cout<<"NO SOLUTION"<<endl;否則如下:

           lcm=A*B/gcd(A,B);所以當我們直接拿C/A,得到的數比B少了gcd,因此要乘回去。

           B=B'*gcd(A,B);gcd(A,B)是一個常數t,因此有B=t*B';

           B=B'*gcd(A,t*B‘),t=gcd(A,t*B')

           如何求t值——通過不斷“吸取”A中的A和B'的公約數來實現這一點

            b=c/a;
            t=gcd(a,b);
            while(t!=1){
                b*=t;
                a/=t;
                t=gcd(a,b);
            }
代碼:

#include <iostream>
#include <cstdio>
using namespace std;
int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int a,b,c,t;
        cin>>a>>c;
        if(c%a!=0)
            cout<<"NO SOLUTION"<<endl;
        else{
            b=c/a;
            t=gcd(a,b);
            while(t!=1){
                b*=t;
                a/=t;
                t=gcd(a,b);
            }
            cout<<b<<endl;
        }
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章