PAT甲級 1139. First Contact (30)

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N <= 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:
10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003
Sample Output:
4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

題目解析:

給n個人,m對朋友關係(有負號的代表女孩)。

k組詢問,每組詢問給出一對關係(a,b)表示a追求b,追求方式:a在認識的人中找一個和a自己同性的c,c在認識的人中找到一個和b同性並且認識b的d。

簡單來說就是a認識c,c認識d,d認識b,並且a和c同性,d和b同性

做法就是a在自己認識的同性中找一個c,b在自己認識的同性中找一個d,判斷一下c和d是否認識就可以了。

注意:

1、id號是用四位數字表示的,所以會有0000和-0000,雖然數值相同,但性別不同;

2、a不能直接找到b,同樣b也不能直接找到a;

3、輸出按第一個id的非遞減,第一個id相同則按第二個id的遞增,並且用%04d輸出。

#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <map>
#include <set>
#include <queue>
#include <vector>
#include <stack>
#include <algorithm>
#include <iostream>
using namespace std;

#define long long ll
const int MAXN = 1e4 + 10;
const int INF = 0x7fffffff;
const int dx[]={0, 1, 0, -1};
const int dy[]={1, 0, -1, 0};
int n, m;
struct NODE{
    vector<int>same;
}node[MAXN];

map<int, map<int, bool> >mp;
struct ANS{
    int idx, idy;
}ans[MAXN];
bool cmp(ANS x, ANS y){
    if(x.idx==y.idx) return x.idy<y.idy;
    return x.idx<y.idx;
}

int main(){
    while(~scanf("%d%d", &n, &m)){
        mp.clear();
        for(int i=0; i<m; i++){
            char x[12], y[12];
            scanf("%s%s", x, y);
            int s=abs(atoi(x)), t=abs(atoi(y));
            mp[s][t]=mp[t][s]=true;
            if(strlen(x)==strlen(y)){///同性
                node[s].same.push_back(t);
                node[t].same.push_back(s);
            }


        }
        int k;
        scanf("%d", &k);
        while(k--){
            int s, t, cnt=0;
            scanf("%d%d", &s, &t);
            s=abs(s), t=abs(t);
            for(int i=0; i<node[s].same.size(); i++){///s認識的同性x
                for(int j=0; j<node[t].same.size(); j++){///t認識的同性y
                    int x=node[s].same[i], y=node[t].same[j];
                    if(x==t || s==y) continue;
                    if(mp[x][y]) ans[cnt].idx=x, ans[cnt++].idy=y;///判斷x和y是否認識
                }
            }
            sort(ans, ans+cnt, cmp);
            printf("%d\n", cnt);
            for(int i=0; i<cnt; i++) printf("%04d %04d\n", ans[i].idx, ans[i].idy);
        }
    }
    return 0;
}





發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章