PAT甲級 1079. Total Sales of Supply Chain (25)

A supply chain is a network of retailers(零售商), distributors(經銷商), and suppliers(供應商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3
Sample Output:
42.4

題目大意:

給一棵樹,樹表示進貨的關係,樹的根表示retailer,會給出從這個retailer中購買多少個商品,商品的價格從root結點開始,逐層增加(100+r)%。

注意:計算該層retailer的售貨價格時用pow(x,y)函數會比用循環體快

#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <map>
#include <set>
#include <queue>
#include <vector>
#include <stack>
#include <algorithm>
#include <iostream>
using namespace std;

const int MAXN = 1e5 + 10;
const int INF = 0x7fffffff;
const int dx[]={0, 1, 0, -1};
const int dy[]={1, 0, -1, 0};
int n;
double p, r;
vector<int>vec[MAXN];
double Bfs(int root){
    double ans=0;
    map<int, int>deep;
    deep.clear();
    deep[0]=0;

    queue<int>que;
    que.push(root);

    while(!que.empty()){
        int fro=que.front();
        que.pop();
        if(vec[fro][0]==-1){///根節點
            ans+=double(vec[fro][1])*p*pow(r, deep[fro]);
        }else{
            for(int i=0; i<vec[fro].size(); i++){
                deep[vec[fro][i]]=deep[fro]+1;
                que.push(vec[fro][i]);
            }
        }
    }
    return ans;
}

int main(){
    while(~scanf("%d%lf%lf", &n, &p, &r)){
        r=1+r/100.0;
        for(int i=0; i<n; i++) vec[i].clear();
        for(int i=0; i<n; i++){
            int k, num;
            scanf("%d", &k);
            if(!k){///根節點
                vec[i].push_back(-1);
                scanf("%d", &num);
                vec[i].push_back(num);
            }
            for(int j=0; j<k; j++){
                scanf("%d", &num);
                vec[i].push_back(num);
            }
        }
        printf("%.1f\n", Bfs(0));
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章