hdu 1686 Oulipo

Oulipo
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19589 Accepted Submission(s): 7656

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

Source
華東區大學生程序設計邀請賽_熱身賽

Recommend
lcy | We have carefully selected several similar problems for you: 1358 1711 3336 3746 2203

題目大意:
給定2個串,輸出一個串在另一個串中出現的次數,共n組

做法:
KMP模板練習。

代碼如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int n, ans, p[10007];
char b[10007], s[1000007];

void work()
{
    memset(p, 0, sizeof(p));
    gets(b + 1);
    gets(s + 1);
    int j = 0;
    int len = strlen(b + 1);
    int len2 = strlen(s + 1);
    for (int i = 2; i <= len; i++)
    {
        while (j > 0 && b[j + 1] != b[i])   j = p[j];
        if (b[i] == b[j + 1])   j += 1;
        p[i] = j;   
    }
    j = 0;
    ans = 0;
    for (int i = 1; i <= len2; i++)
    {
        while (j > 0 && b[j + 1] != s[i])   j = p[j];
        if (b[j + 1] == s[i])   j++;
        if (j == len)
        {
            ans++;
            j = p[j];
        }
    }
    printf("%d\n", ans);
}

int main()
{
    scanf("%d", &n);
    char ch = getchar();
    for (int i = 1; i <= n; i++)
        work(); 
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章