HDU 1028 Ignatius and the Princess III

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13171    Accepted Submission(s): 9316


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627
 

Author
Ignatius.L
解題思路:求正整數n的無序拆分方案數,令dp[i][j]表示將i拆成最大拆分數不超過j的方案種數
考慮若j==i,那麼dp[i][j]=dp[i][j-1]+1;
若j>i,那麼dp[i][j]=dp[i][i];
若j<i,那麼dp[i][j]=dp[i][j-1]+dp[i-j][j];
#include"stdio.h"
#include"string.h"
int main()
{
    int n;
    int dp[130][130];
    int i,l;
    
    memset(dp,0,sizeof(dp));
    dp[1][1]=1;
    for(i=1;i<=130;i++)
    {
        dp[i][1]=1;
        dp[1][i]=1;
    }
    for(i=2;i<=120;i++)
    {
        for(l=2;l<=120;l++)
        {
            if(l>i)
                dp[i][l]=dp[i][i];
            else if(l==i)
                dp[i][l]=dp[i][l-1]+1;
            else
                dp[i][l]=dp[i][l-1]+dp[i-l][l];
        }
    }


    while(scanf("%d",&n)!=EOF)
        printf("%d\n",dp[n][n]);


    return 0;
}


 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章