HDU 3033 I love sneakers!

I love sneakers!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3954    Accepted Submission(s): 1631


Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.
 

Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.
 

Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.
 

Sample Input
5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66
 

Sample Output
255
 

Source
解題思路:簡單的分組揹包
#include<iostream>
#include<cstdio>
#include<cstring>
#define Inf 0x7fffffff
using namespace std;
struct
{
    int val;
    int cost;
}goods[11][105];
int main()
{
    int i,j,n,money,k,p,dp[11][10005],num[11],a,b,c;
    while(~scanf("%d%d%d",&n,&money,&k))
    {
        memset(dp,-1,sizeof(dp));
        memset(num,0,sizeof(num));
        memset(dp[0],0,sizeof(dp[0]));
        for(i=1;i<=n;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            goods[a][num[a]].cost=b;
            goods[a][num[a]].val=c;
            num[a]++;
        }
        for(i=1;i<=k;i++)
        {
            for(j=0;j<num[i];j++)
            {
                for(p=money;p>=goods[i][j].cost;p--)
                {
                    if(dp[i][p-goods[i][j].cost]!=-1)
                        dp[i][p]=max(dp[i][p],dp[i][p-goods[i][j].cost]+goods[i][j].val);
                    if(dp[i-1][p-goods[i][j].cost]!=-1)
                        dp[i][p]=max(dp[i][p],dp[i-1][p-goods[i][j].cost]+goods[i][j].val);
                }
            }
        }
        if(dp[k][money]<0)
            printf("Impossible\n");
        else
            printf("%d\n",dp[k][money]);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章