POJ - 2923 Relocation(狀態壓縮+01揹包)

題目鏈接:http://poj.org/problem?id=2923點擊打開鏈接

Relocation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3684 Accepted: 1505

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers nC1 and C2C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

題目大意:t組樣例

給n個物品 容量c1 容量c2

然後給出n個物品所需容量 每次搬運同時使用c1和c2容量 問搬完最少需要多少次

因爲n的值很小 因此可以考慮使用狀態壓縮

通過枚舉所有狀態 判斷出能夠被一次搬走有哪些狀態 將這些狀態視爲物品 然後進行01揹包dp

dp【i】表示在i狀態下需要搬運的最少次數

注意判斷是否能一次搬走當前狀態時也可用01揹包

#include <vector>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int n,c1,c2;
int a[111];
int check(int num)
{
    vector<int >ss;
    ss.clear();
    int sum=0;
    for(int i=0;i<n;i++)
    {
        if(((1<<i)&num)!=0)
        {
            ss.push_back(a[i]);
            sum+=a[i];
        }
    }
    int dpp[111];
    memset(dpp,0,sizeof(dpp));
    dpp[0]=1;
    int len=ss.size();
    for(int i=0;i<len;i++)
    {
        for(int j=c1;j>=ss[i];j--)
        {
            if(dpp[j-ss[i]]!=0)
                dpp[j]=1;
        }
    }
    for(int i=0;i<=c1;i++)
    {
        if(dpp[i]!=0)
        {
            if(sum-i<=c2)
                return 1;
        }
    }
    return 0;

}
int main()
{
    int t;
    scanf("%d",&t);
    for(int cnt=1;cnt<=t;cnt++)
    {
        vector<int > s;
        s.clear();
        scanf("%d%d%d",&n,&c1,&c2);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        int tot=(1<<n)-1;
        for(int i=1;i<=tot;i++)
        {
            if(check(i))
            {
                s.push_back(i);
            }
        }
        int len=s.size();
        int dp[tot+1];
        for(int i=0;i<=tot;i++)
        {
            dp[i]=11111;
        }
        dp[0]=0;
        for(int i=0;i<len;i++)
        {
            int now=s[i];
            for(int j=tot;j>=0;j--)
            {
                if((now&j)==0)
                {
                    if(dp[now|j]>dp[j]+1)
                        dp[now|j]=dp[j]+1;
                }
            }
        }
        printf("Scenario #%d:\n",cnt);
        printf("%d\n",dp[tot]);
        if(cnt!=n)
            printf("\n");
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章