hdu 3455 Leap Frog

 
Problem Description
Jack and Jill play a game called "Leap Frog" in which they alternate turns jumping over each other. Both Jack and Jill can jump a maximum horizontal distance of 10 units in any single jump. You are given a list of valid positions x1,x2,…, xn where Jack or Jill may stand. Jill initially starts at position x1, Jack initially starts at position x2, and their goal is to reach position xn.Determine the minimum number of jumps needed until either Jack or Jill reaches the goal. The two players are never allowed to stand at the same position at the same time, and for each jump, the player in the rear must hop over the player in the front.
 


 

Input
The input file will contain multiple test cases. Each test case will begin with a single line containing a single integer n (where 2 <= n <= 100000). The next line will contain a list of integers x1,x2,…, xn where 0 <=x1,x2,…, xn<= 1000000. The end-of-fi le is denoted by a single line containing "0".
 


 

Output
For each input test case, print the minimum total number of jumps needed for both players such that either Jack or Jill reaches the destination, or -1 if neither can reach the destination.
 


 

Sample Input
6 3 5 9 12 15 17 6 3 5 9 12 30 40
 


 

Sample Output
3 -1

 

 

//

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=101000;
int n;
int a[maxn];
int f[maxn][12];//dp[i][j]表示i位置,i+j位置的兩個人
int main()
{
    while(scanf("%d",&n)==1&&n)
    {
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        memset(f,-1,sizeof(f));
        f[1][1]=0;
        for(int i=2;i<=n;i++)
        {
            for(int j=1;i+j<=n&&a[i+j]-a[i]<=10;j++)
            {
                for(int k=1;i-k>=1&&a[i+j]-a[i-k]<=10;k++)
                {
                    if(f[i-k][k]==-1) continue;
                    if(f[i][j]==-1) f[i][j]=f[i-k][k]+1;
                    else f[i][j]=min(f[i][j],f[i-k][k]+1);
                }
            }
        }
        int ans=-1;
        for(int i=n-1;i>=1&&a[n]-a[i]<=10;i--)
        {
            if(f[i][n-i]==-1) continue;
            if(ans==-1) ans=f[i][n-i];
            else ans=min(ans,f[i][n-i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章