poj2417 Discrete Logging(BSGS:Baby Step Giant Step)

Discrete Logging
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 4283   Accepted: 1970

Description

Given a prime P, 2 <= P < 231, an integer B, 2 <= B < P, and an integer N, 1 <= N < P, compute the discrete logarithm of N, base B, modulo P. That is, find an integer L such that 
    BL == N (mod P)

Input

Read several lines of input, each containing P,B,N separated by a space.

Output

For each line print the logarithm on a separate line. If there are several, print the smallest; if there is none, print "no solution".

Sample Input

5 2 1
5 2 2
5 2 3
5 2 4
5 3 1
5 3 2
5 3 3
5 3 4
5 4 1
5 4 2
5 4 3
5 4 4
12345701 2 1111111
1111111121 65537 1111111111

Sample Output

0
1
3
2
0
3
1
2
0
no solution
no solution
1
9584351
462803587

Hint

The solution to this problem requires a well known result in number theory that is probably expected of you for Putnam but not ACM competitions. It is Fermat's theorem that states 
   B(P-1) == 1 (mod P)

for any prime P and some other (fairly rare) numbers known as base-B pseudoprimes. A rarer subset of the base-B pseudoprimes, known as Carmichael numbers, are pseudoprimes for every base between 2 and P-1. A corollary to Fermat's theorem is that for any m 
   B(-m) == B(P-1-m) (mod P) .

題意:求L使B的L次冪與N對P同餘。

題目很短,一開始以爲是數學題,想着還要推公式,好麻煩。後來才發現有hint,但是並沒有什麼用,因爲按公式敲完一定會超時。學長說用BSGS做,就找了一下模板,半知半解吧,沒有完全搞懂,就當收集了一個新模板吧,感覺BSGS算法大多是都是解數學題,以後再做類似題的時候再做擴展。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#define maxn 76567

using namespace std;

int head[maxn], nextt[maxn], e[maxn], cnt, hash[maxn];

int find(int x)
{
    int k = x % maxn;
    for(int i = head[k]; i != -1; i = nextt[i])
    {
        if(hash[i] == x)
            return e[i];
    }
    return -1;
}

int BSGS(int b, int n, int p)
{
    memset(head, -1, sizeof(head));
    cnt = 1;
    if(n == 1)
        return 0;
    int m = sqrt(p);
    long long q = 1;
    for(int i = 0; i < m; i++)
    {
        int k = ((q * n) % p) % maxn;
        hash[cnt] = (q * n) % p;
        e[cnt] = i;
        nextt[cnt] = head[k];
        head[k] = cnt;
        cnt++;
        q = q * b % p;
    }
    int j;
    long long x = 1;
    for(long long i = m; ; i += m)
    {
        if((j = find(x = x * q % p)) != -1)
            return i - j;
        if(i > p)
            break;
    }
    return -1;
}

int main()
{
    int p, n, b;
    while(scanf("%d%d%d", &p, &b, &n) != EOF)
    {
        int ans = BSGS(b, n, p);
        if(ans == -1)
            printf("no solution\n");
        else
            printf("%d\n",ans);
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章