HDU1241: DFS(深搜)

HUD1241: Oil Deposits

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2
這道題大概意思就是,輸入兩個數代表行和列,其中”@”代表有油,“*”代表沒有油,而一個油周圍8個方位假如有油,則看成是同一個油礦,最後輸出圖中有多少的油礦

#include<iostream>
using namespace std;

int N,M;  //代表行和列
char map[109][109]; //存儲地圖

int dp[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
//代表周圍八個方向

//深搜
void find(int x,int y)
{
    for(int i=0;i<8;i++)//分別走八個方向
    {
        int nx=x+dp[i][0];  //列更新
        int ny=y+dp[i][1];  //行更新

        if(nx<N&&nx>=0&&ny>=0&&ny<M)  //判斷是否越界
        if(map[nx][ny]=='@')   //判斷更新後是否有油
        {
            map[nx][ny]='*';  //將有油變爲沒油,防止重複
            find(nx,ny);
        }
    }
}

int main()
{
    while(cin>>N>>M&&N&&M) 
    {

        int sum=0; //油礦數目

        for(int i=0;i<N;i++)
        {
            cin>>map[i];
        }

        //尋找有油的地方,變爲沒有,進入深搜
        //深搜的過程就是去找周圍八個方向,在不越界的情況下,在有油時,則進入下一次遞歸,沒有油則繼續查找
        for(int i=0;i<N;i++)
        {
            for(int j=0;j<M;j++)
            {
                if(map[i][j]=='@')
                {
                    map[i][j]='*';
                    find(i,j);
                    sum++;
                }
            }
        }
        cout<<sum<<endl;
    }
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章