動態規劃之完全揹包搭配題目HDU1114:Piggy-Bank

HDU1114: Piggy-Bank

Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

完全揹包問題,與01揹包不同的是,完全揹包要求的就是揹包必須完全裝滿,例如本題的第一個例子,存錢罐不裝錢重量是10,裝完是110,所以裏面的所裝的前的重量就是100,不能多也不能少,並且,完全揹包有個特點,就是東西都是無限的,就像本題的貨幣,不限量,在動態規劃過程中,dp需要從小到大遍歷,具體分析在代碼部分講解

代碼如下:

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
int main()
{
    int T;
    int start,now; //聲明存錢罐原先的重量和現在的重量
    int N;  //貨幣的種類
    int value[509],weight[509],dp[10009];//分別代表貨幣的價值,貨幣的重量,動態規劃揹包重量所能裝的最小价值
    int temp;//中間變量
    
    cin>>T;
    while(T--)
    {
    	//輸入
        cin>>start>>now;
        cin>>N;
        
        for(int i=1;i<=N;i++){
            cin>>value[i]>>weight[i];
        }
        
        //memset(dp,0x3f,sizeof(dp)指的是把dp這個數組的每一個字節都變成0x3f,而每個字節的最大值是0x3f,所以這行代碼
        代表的是把dp數組變得最大
        memset(dp,0x3f,sizeof(dp));
        dp[0]=0;//同時把dp[0]變成0,下面能起到一個關鍵的作用
       
        for(int i=1;i<=N;i++){     //遍歷每一種貨幣
            for(int j=weight[i];j<=now-start;j++){      
            
				 temp=value[i]+dp[j-weight[i]];
                
                if(temp>0)
                if(temp<dp[j])
                dp[j]=temp;
                
            }
        }
        /*“ temp=value[i]+dp[j-weight[i]];“,value[i]是當前貨幣的價值,這個貨幣的重量是weight[i],
        dp[j-weight[i]]的意義是當前存錢罐中錢的重量爲  j   ,dp[j-weight[i]]表示剩下的重量在之前所能代
        表的最小价值
        在上面的代碼中初始化dp時,其他都是最大,唯獨dp[0]=0,原因就是,假如有一塊錢的貨幣重量爲1,那麼
        dp[0]=0,dp[1]=value[1]+dp[0], dp[0]的用處便是可以在遍歷過程中減少麻煩
        而爲什麼要判斷temp>0呢?開頭也說過初始化dp,把它變成一個最大的數,只要這個數加上另一個大於零的數,
        那麼結果就會溢出,變成一個負數。這一步的所用就在於,假如當前遍歷的貨幣是1,重量是2,且只有這一種
        貨幣,那麼遍歷是從2開始的,當運算到dp[3]時,dp[3]=1+dp[1];算出的結果dp[3]等於一個最大數加上1,
        溢出,變成一個最小數。
        而 if(temp<dp[j])則是判斷假如當前的貨幣,假如實際價值更小,則替換。因爲結果是要輸出存錢罐裏最少有多少錢
        */
//假如最終dp[now-start]==dp[10008]  ,則代表找不到能匹配的貨幣
        if(dp[now-start]==dp[10008]){
        	
            cout<<"This is impossible."<<endl;
            
        }
        else
        {
        	//輸出結果
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[now-start]);
        
		}
    }
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章