hdu 1114 Piggy Bank (完全揹包 要求正好裝滿)

題目鏈接:hdu 1114

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

題有點長,大意是說給T組數據,每組數據的開始是E和F兩個數,分別代表存錢罐空時和滿時的重量,接下來告訴你有N種硬幣,以及每種硬幣的P(價值)和W(重量),要求裝入總價值最少的硬幣使存錢罐正好能夠達到F的重量。

剛開始接觸揹包時,做的揹包題目都是要求揹包裝的價值儘可能大,並沒有要求正好完全裝滿。而要把揹包正好裝滿,也並不需要太多改動,只需在初始化的時候只把dp[0]初始化爲0,其餘都設置爲未定義,無合法解的狀態即可。

對應到程序中可以初始化爲-INF,這道題要求的是最小价值,因此初始化爲INF。

具體原因參照《揹包九講》關於初始化的細節問題。

F - E爲揹包最大容限,因爲初始化時設定的是dp[0] = 0,所以起始點必須是0,最大爲F - E,這裏是一個小細節。

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 10010
#define MM 505
#define INF 0x3f3f3f3f

using namespace std;

int w[MM];
int c[MM];
int dp[MAX];

int main()
{
    int T;
    while(~scanf("%d", &T) && T >= 0)
    {
        while(T--)
        {
            int E, F;
            scanf("%d %d", &E, &F);
            int N;
            scanf("%d", &N);
            for(int i = 0; i < N; i++)
            {
                scanf("%d %d", &w[i], &c[i]);
            }
            memset(dp, INF, sizeof(dp));
            dp[0] = 0;
            for(int i = 0; i < N; i++)
            {
                for(int j = c[i]; j <= F - E; j++)
                {
                    dp[j] = min(dp[j], dp[j - c[i]] + w[i]);
                }
            }
            if(dp[F - E] == INF)
                printf("This is impossible.\n");
            else
                printf("The minimum amount of money in the piggy-bank is %d.\n", dp[F - E]);
        }
    }
    return 0;
}

運行結果:
這裏寫圖片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章