1132 Cut Integer (20 分)(cj)

1132 Cut Integer (20 分)

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <stdio.h>
#include <string>
using namespace std;
int tran(string s);
int main() {
	int n;
	cin >> n;
	string str;
	while (n--) {
		cin >> str;
		int a = tran(str);
		int b = tran(str.substr(0, str.size() / 2));
		int c = tran(str.substr(str.size() / 2));
		if ((b*c) == 0) {
			cout << "No" << endl;
		}
		else if (a % (b*c) == 0) {
			cout << "Yes" << endl;
		}
		else cout << "No" << endl;
	}
	system("pause");
	return 0;
}
int tran(string s) {
	int sum = 0;
	for (int i = 0; i < s.size(); ++i) {
		sum *= 10;
		sum += s[i] - '0';
	}
	return sum;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章