(PAT)1154 Vertex Coloring (25分)(cj)

聲明: 博客內所有英文題目來自 https://pintia.cn/  中 PAT(Advanced Level) Practice, 博客內容只用於學術目的,僅爲PAT入門提供一個參考,不用於任何商業行爲。 轉載請註明出處。

                                                                  1154 Vertex Coloring (25分)

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

思路:圖的塗色問題, 可以試試遞歸搜索 加判斷周圍結點是否共色。

Code:

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <stack>
#include <set>
#define abs(x) (x>0?x:-x)
#define edge 0x7fffffff
using namespace std;

vector<int> graph[10005];
int vertex[10004];
bool check(int len){   
    for(int i=0;i<len;++i){
        int length = graph[i].size();
        for(int j=0;j<length;++j){
            int tmp = graph[i][j];
            if(vertex[i]==vertex[tmp]) return 0;
        }
    }
    return 1;
}

int main(){
    int n,m;
    scanf("%d %d",&n,&m);
    int e1,e2;
    for(int i=0;i<m;++i){
        scanf("%d %d",&e1,&e2);
        graph[e1].push_back(e2);
        graph[e2].push_back(e1);
    }
    int k;
    scanf("%d",&k);
    for(int i=0;i<k;++i){
        set<int> ss;
        for(int j=0;j<n;++j){
            scanf("%d",&vertex[j]);
            ss.insert(vertex[j]);
        }
        int k_color = ss.size();
        bool res = check(n);
        if(res){
            printf("%d-coloring\n",k_color);
        }
        else{
            printf("No\n");
        }
    }


    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章