1141 PAT Ranking of Institutions (25 分)(cj)

1141 PAT Ranking of Institutions (25 分)

After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Scoreis an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

code

#pragma warning(disable:4996)
#include <iostream>
#include <string>
#include <map>
#include <vector>
#include <algorithm>
using namespace std;
class node {
public:
	string name;
	double weightedscore = 0;
	int num = 0;
};
map<string, node> mp;
void lower(string &s);
bool cmp(node& a, node& b);
int main() {
	int n;
	cin >> n;
	string name, school;
	int score;
	for (int i = 0; i < n; ++i) {
		cin >> name >> score >> school;
		lower(school);
		mp[school].num++;
		double p = 1.0;
		if (name[0] == 'B') p = 2.0 / 3;
		else if (name[0] == 'T') p = 3.0 / 2;
		mp[school].weightedscore += p*score;
	}
	vector<node> varr;
	for (auto it = mp.begin(); it != mp.end(); ++it) {
		it->second.name = it->first;
		it->second.weightedscore = int(it->second.weightedscore);
		varr.push_back(it->second);
	}
	sort(varr.begin(), varr.end(), cmp);
	cout << varr.size() << endl;
	int rank = 0;
	for (int i = 0; i < varr.size(); ++i) {
		if (rank == 0 || varr[i].weightedscore != varr[i - 1].weightedscore) {
			rank = i + 1;
		}
		cout << rank << ' ';
		cout << varr[i].name << ' ' << varr[i].weightedscore << ' ' << varr[i].num << endl;
	}
	system("pause");
	return 0;
}
void lower(string & s) {
	for (int i = 0; i < s.size(); ++i) {
		s[i] = tolower(s[i]);
	}
}
bool cmp(node& a, node& b) {
	if (a.weightedscore == b.weightedscore) {
		if (a.num == b.num) return a.name < b.name;
		return a.num < b.num;
	}
	return a.weightedscore > b.weightedscore;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章