1151 LCA in a Binary Tree (30 分)(cj)

1151 LCA in a Binary Tree (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y.where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <stdio.h>
#define inf 0x7fffffff
using namespace std;
class tree {
public:
	int val;
	tree* left = NULL, *right = NULL;
};
vector<int> preorder;
vector<int> inorder;
int x, y, tmp;
void buildtree(int q,int e, int l, int r, tree*& p);
void pretravel(tree*& p);
int travel(tree* p);
int main() {
	int m, n;
	cin >> m >> n;
	for (int i = 0; i < n; ++i) {
		cin >> x;
		inorder.push_back(x);
	}
	for (int i = 0; i < n; ++i) {
		cin >> x;
		preorder.push_back(x);
	}
	tree* head = NULL;
	buildtree(0, n - 1, 0, n - 1, head);
	//pretravel(head);
	//cout << endl;
	for (int i = 0; i < m; ++i) {
		cin >> x >> y;
		tmp = inf;
		int g = travel(head);
		if (g == 1) {
			if (tmp != inf) printf("%d is an ancestor of %d.\n", x, y);
			else printf("ERROR: %d is not found.\n", y);
		}
		else if (g == 2) {
			if (tmp != inf) printf("%d is an ancestor of %d.\n", y, x);
			else printf("ERROR: %d is not found.\n", x);
		}
		else if (g == 0) printf("ERROR: %d and %d are not found.\n", x, y);
		else printf("LCA of %d and %d is %d.\n", x, y, tmp);
	}
	system("pause");
	return 0;
}
int travel(tree* p) {
	if (p == NULL) return 0;
	if (p->val == x) {
		int g = travel(p->left);
		g += travel(p->right);
		if (p->val == y) g++;
		if (g != 0) tmp = y;
		return 1;
	}
	if (p->val == y) {
		int g = travel(p->left);
		g += travel(p->right);
		if (p->val == x) g++;
		if (g != 0) tmp = x;
		return 2;
	}
	int g = 0;
	g += travel(p->left);
	if (g == 3) {
		if (tmp == inf) tmp = p->val;
		return g;
	}
	g += travel(p->right);
	if (g == 3) {
		if (tmp == inf) tmp = p->val;
		return g;
	}
}
void pretravel(tree*& p) {
	if (p == NULL) return;
	cout << p->val << ' ';
	pretravel(p->left);
	pretravel(p->right);
}
void buildtree(int q, int e, int l, int r, tree*& p) {
	if (l >	r) return;
	p = new tree;
	p->val = preorder[l];
	if (l == r) return;
	int pos;
	for (pos = q; pos <= e; ++pos) {
		if (inorder[pos] == preorder[l]) break;
	}
	buildtree(q , pos-1, l + 1, l + pos - q, p->left);
	buildtree(pos + 1, e, l + pos - q +1 , r, p->right);
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章