1149 Dangerous Goods Packaging (25 分)(cj)

1149 Dangerous Goods Packaging (25 分)

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化劑) must not be packed with flammable liquid (易燃液體), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10​4​​), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] ... G[K]

where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:

For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:

6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333

Sample Output:

No
Yes
Yes

pintia 新掛的題 主要坑點就是 時間問題了 可以通過減少開闢的空間 和 算法時間複雜度 來減少時間。

比如 我用map 來代替 開闢 100000 個數組。當然map 初始化的時間要大於 數組開闢時間 但是 map 勝在數量少。 

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <set>
#include <stdio.h>
#include <map>
#define inf 0x7fffffff
using namespace std;
map<int, set<int>> mp;
int main() {
	int n, m;
	scanf(" %d %d", &n, &m);
	int x, y;
	for (int i = 0; i < n; ++i) {
		scanf("%d %d", &x, &y);
		mp[x].insert(y);
		mp[y].insert(x);
	}
	int k;
	set<int> ss;
	for (int i = 0; i < m; ++i) {
		scanf("%d", &k);
		ss.clear();
		bool f = 1;
		while (k--) {
			scanf("%d", &x);
			if (f == 0) continue;
			if (mp.count(x) == 1) {
				for (auto it = ss.begin(); it != ss.end(); ++it) {
					if (mp[x].find(*it) != mp[x].end()) {
						f = 0;
						break;
					}
				}
			}
			if(f) ss.insert(x);
		}
		if (f) printf("Yes\n");
		else printf("No\n");
	}
	system("pause");
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章