1150 Travelling Salesman Problem (25 分)(cj)

1150 Travelling Salesman Problem (25 分)

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C​1​​ C​2​​ ... C​n​​

where n is the number of cities in the list, and C​i​​'s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

不多說了。。。 暴力題 需要紮實的編程基礎。 

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <stdio.h>
#define inf 0x7fffffff
using namespace std;
int map[205][205];
int vis[205];
int main() {
	int n, m;
	cin >> n >> m;
	int x, y, d;
	for (int i = 0; i < m; ++i) {
		cin >> x >> y >> d;
		map[x][y] = d;
		map[y][x] = d;
	}
	int k, num;
	cin >> k;
	int min_d = 0x7fffffff, min_p = 0;
	for (int i = 0; i < k; ++i) {
		cin >> num;
		int d = 0, pos = 0, ppos = 0;
		int t = 0;
		for (int i = 1; i <= n; ++i) {
			vis[i] = 0;
		}
		while (num--) {
			cin >> x;
			vis[x]++;
			if (d == -1) continue;
			if (pos == 0) {
				pos = x;
				ppos = x;
				continue;
			}
			if (map[pos][x] == 0) {
				d = -1;
				continue;
			}
			else d += map[pos][x];
			pos = x;
		}
		cout << "Path " << i + 1 << ": ";
		if (d == -1) {
			cout << "NA ";
			cout << "(Not a TS cycle)" << endl;
		}
		else cout << d<<' ';
		if (d != -1) {
			bool f1 = 0,f2=0;
			int g = 0;
			for (int i = 1; i <= n; ++i) {
				//cout << vis[i] << ' ';
				if (vis[i] > 1) {
					g++;
					if (i == ppos) f2 = 1;
				}
				if (vis[i] == 0) {
					f1 = 1;
					break;
				}
			}
			//cout << endl;
			//cout << f1 << ' ' << g <<' '<< f2<<endl;
			if (f1 || g == 0 || f2==0) cout << "(Not a TS cycle)";
			if (g > 1 && f2) {
				cout << "(TS cycle)";
				if (d < min_d) {
					min_d = d;
					min_p = i + 1;
				}
			}
			if (f1 == 0 && g == 1 && f2) {
				cout << "(TS simple cycle)";
				if (d < min_d) {
					min_d = d;
					min_p = i + 1;
				}
			}
			cout << endl;
		}
	}
	printf("Shortest Dist(%d) = %d", min_p, min_d);
	system("pause");
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章