(PAT)1155 Heap Paths (30分)(cj)

聲明: 博客內所有英文題目來自 https://pintia.cn/  中 PAT(Advanced Level) Practice, 博客內容只用於學術目的,僅爲PAT入門提供一個參考,不用於任何商業行爲。 轉載請註明出處。

                                                                     1155 Heap Paths (30分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

思路:一個完整二叉樹 是很容易用一個一維數組處理的,pos*2 到左子節點,pos*2+1到右子結點。遞歸遍歷所有結點並把經過節點保存下來。因爲路徑可能會結點都相等,以至於無法判斷最大堆還是最小堆,所以把這些路徑保存下來整體判斷。

Code:

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <stack>
#define abs(x) (x>0?x:-x)
#define edge 0x7fffffff
using namespace std;


void dfs(vector< vector<int> >& paths,int* arr,int* path,int idex,int pos,int len){
    path[idex] = arr[pos];
    if(pos*2>len) {
        vector<int> tmp;
        for(int i=0;i<=idex;++i){
            tmp.push_back(path[i]);
            //printf("%d ",path[i]);
        }
        //printf("\n");
        paths.push_back(tmp);
    }
    if(pos*2+1<=len) dfs(paths,arr,path,idex+1,pos*2+1,len);
    if(pos*2<=len) dfs(paths,arr,path,idex+1,pos*2,len);
}
int main(){
    int n;
    vector< vector<int> > paths; 
    int path[12];
    scanf("%d",&n);
    int arr[1004];
    for(int i=1;i<=n;++i){
        scanf("%d",&(arr[i]));
    }
    dfs(paths,arr,path,0,1,n);
    int len1=paths.size();
    int flagmax = 1;
    int flagmin = 1;
    for(int i=0;i<len1;++i){
        int len2=paths[i].size();
        printf("%d",paths[i][0]);
        for(int j=1;j<len2;++j){
            if(paths[i][j]>paths[i][j-1]) flagmax=0;
            if(paths[i][j]<paths[i][j-1]) flagmin=0;
            printf(" %d",paths[i][j]);
        }
        printf("\n");
    }
    if(flagmax) printf("Max Heap");
    if(flagmin) printf("Min Heap");
    if(flagmax==0&&flagmin==0) printf("Not Heap");
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章