(PAT)1153 Decode Registration Card of PAT (25分) (cj)

聲明: 博客內所有英文題目來自 https://pintia.cn/  中 PAT(Advanced Level) Practice, 博客內容只用於學術目的,僅爲PAT入門提供一個參考,不用於任何商業行爲。

                                            1153 Decode Registration Card of PAT (25分)

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

思路: 將問題拆爲三個部分,第一部分查找加排序,可以用創建一個結構體struct 來排序, 第二部分是查找後相加,第三部分也可以用第一部分的結構體, 使用mp[ 107] ++ 保存每個考場的人數, 並把107轉成字符放入結構體排序。  

Code:

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <stack>
#include <set>
#include <cstring>
#define abs(x) (x>0?x:-x)
#define edge 0x7fffffff
using namespace std;

struct node{
    node(char *x,int y){
        score = y;
        strcpy(card,x);
    }
    char card[15]={0};
    int score = 0;
};

bool cmp1(node& x, node& y){
    if(x.score == y.score){
        return strcmp(x.card,y.card)<0;
    }
    return x.score > y.score;
}
void qury1(vector<node>& varr,char* term){
    char level = term[0];
    vector<node> res;
    int len = varr.size();
    bool f = 1;
    for(int i=0;i<len;++i){
        if(varr[i].card[0]==level){
            f=0;
            res.push_back(varr[i]);
        }
    }
    if(f==0){
        sort(res.begin(),res.end(),cmp1);
        len = res.size();
        for(int i=0;i<len;++i){
            printf("%s %d\n",res[i].card,res[i].score);
        }
    }
    else printf("NA\n");
}
void qury2(vector<node>& varr,char* term){
    int len = varr.size();
    bool f=1;
    int count = 0;
    int sum =0;
    for(int i=0;i<len;++i){
        bool ff = 1;
        for(int j=1;j<=3;++j){
            if(term[j-1]!=varr[i].card[j]){
                ff=0;
                break;
            }
        }
        if(ff){
            f = 0;
            count++;
            sum+=varr[i].score;
        }
    }
    if(f==0) printf("%d %d\n",count,sum);
    else printf("NA\n");
}

void qury3(vector<node>& varr,char* term){
    int len = varr.size();
    bool f = 1;
    map<int,int> mp;
    vector<node> res;
    for(int i=0;i<len;++i){
        bool ff =1;
        for(int j=4;j<=9;++j){
            if(term[j-4]!=varr[i].card[j]){
                ff=0;
                break;
            }
        }
        if(ff){
            f=0;
            int key = (varr[i].card[1]-'0')*100+(varr[i].card[2]-'0')*10+varr[i].card[3]-'0';
            mp[key]++;
        }
    }
    if(f==0){
        char tmp[15]={0};
        for(map<int,int>::iterator it = mp.begin();it!=mp.end();++it){
            int x = it->first;
            tmp[0] = x/100+'0';
            tmp[1] = (x%100)/10+'0';
            tmp[2] = x%10+'0';
            tmp[3] = 0;
            res.push_back(node(tmp,it->second));
        }   
        sort(res.begin(),res.end(),cmp1);
        int len = res.size();
        for(int i=0;i<len;++i){
            printf("%s %d\n",res[i].card,res[i].score);
        }
    }
    else{
        printf("NA\n");
    }
}

int main(){
    vector<node> varr;
    int n,m;
    char card[15];
    int score;
    scanf("%d %d",&n,&m);
    for(int i=0;i<n;++i){
        scanf("%s %d",card,&score);
        varr.push_back(node(card,score));
    }
    int id;
    char term[15];
    for(int i=0;i<m;++i){
        scanf("%d %s",&id,term);
        printf("Case %d: %d %s\n",i+1,id,term);
        if(id == 1){
            qury1(varr,term);
        }
        else if(id==2){
            qury2(varr,term);
        }
        else if(id==3){
            qury3(varr,term);
        }
    }


    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章