1144 The Missing Number (20 分)(cj)

1144 The Missing Number (20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

code

#pragma warning(disable:4996)
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <map>
using namespace std;
vector<int> varr;
int main() {
	int n, x;
	cin >> n;
	for (int i = 0; i < n; ++i) {
		cin >> x;
		varr.push_back(x);
	}
	sort(varr.begin(), varr.end());
	int res = 1;
	for (int i = 0; i < n; ++i) {
		if (varr[i] > res) break;
		else if (varr[i] == res) res++;
	}
	cout << res;
	system("pause");
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章