1148 Werewolf - Simple Version (20 分)

 

1148 Werewolf - Simple Version (20 分)

Werewolf(狼人殺) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

題目的數據規模很小,但是很難想。 就是 倆個狼人 一個說謊  和一個說謊的平民 , 直接枚舉暴力即可。 

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int varr[105];
int map[105];
int tmp[105];
int n, x;
void init();
int main() {
	cin >> n;
	for (int i = 1; i <= n; ++i) {
		cin >> varr[i];
	}
	bool f = 1, ff = 0;
	for (int i = 1; i < n; ++i) {
		for (int j = i + 1; j <= n; ++j) {
			for (int k = 1; k <= n; ++k) {
				if (k == i || k == j) continue;
				init();
				tmp[i] = -varr[i];
				tmp[k] = -varr[k];
				map[i] = 1;
				map[j] = 1;
				for (int i = 1; i <= n; ++i) {
					if ((tmp[i] > 0 && map[tmp[i]] == 0) || (tmp[i] < 0 && map[-tmp[i]] == 1));
					else {
						f = 0;
						break;
					}
				}
				if (f == 1) {
					cout << i << ' ' << j << endl;
					ff = 1;
					break;
				}
				else f = 1;
				if (i == 1 && j == 4) {
			
				}
				init();
				tmp[j] = -varr[j];
				tmp[k] = -varr[k];
				map[i] = 1;
				map[j] = 1;
				for (int i = 1; i <= n; ++i) {
					if ((tmp[i] > 0 && map[tmp[i]] == 0) || (tmp[i] < 0 && map[-tmp[i]] == 1));
					else {
						f = 0;
						break;
					}
				}
				if (f == 1) {
					cout << i << ' ' << j << endl;
					ff = 1;
					break;
				}
				else f = 1;
			}
			if (ff == 1) break;
		}
		if (ff == 1) break;
	}
	if (ff == 0) cout << "No Solution" << endl;
	system("pause");
	return 0;
}
void init() {
	for (int i = 1; i <= n; ++i) {
		tmp[i] = varr[i];
		map[i] = 0;
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章