PAT (Advanced Level) Practice 1065 A+B and C (64bit) (20 分)(C++)(甲級)

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2
​63
​​ ,2
​63
​​ ], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:

Case #1: false
Case #2: true
Case #3: false

//這個題在乙級題中已經做過了,當時的一種方案直接拿過來把int改成long long int 直接就通過了
//兩個正數相加溢出爲正數,兩個負數相加溢出爲正數
//正負相加不會溢出

#include <cstdio>
#include <cstring>
#include <cmath>

int main()
{
	int T = 0;
	long long int A, B, C;
	scanf("%d", &T);
	for (int i = 1; i <= T; i++)
	{
		scanf("%lld %lld %lld", &A, &B, &C);
		long long int D = A + B;
		if (D <= 0 && A>0 && B > 0) printf("Case #%d: true\n", i);//判斷越界時的狀態
		else if (D >= 0 && A < 0 && B < 0) printf("Case #%d: false\n", i);
		else if (D > C) printf("Case #%d: true\n", i);//否則正常比較輸出即可
		else printf("Case #%d: false\n", i);
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章