hdu1059(倒數第二天第二題)

題目:
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0’’. The maximum total number of marbles will be 20000.

The last line of the input file will be 0 0 0 0 0 0''; do not process this line. Output For each colletcion, outputCollection #k:’’, where k is the number of the test case, and then either Can be divided.'' orCan’t be divided.’’.

Output a blank line after each test case.
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
Sample Output
Collection #1:
Can’t be divided.

Collection #2:
Can be divided.

要用動態規劃+二進制優化

二進制優化:原本14個6要檢驗14次,現在變成
兩個16
兩個2
6
兩個4*6
僅僅需要檢驗6次,可以加快速度
代碼:

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
	int yy = 0;
	int a[6];
	while (cin >> a[0] >> a[1] >> a[2] >> a[3] >> a[4] >> a[5])
	{
		int all = 0;
		for (int i = 0; i < 6; i++)
		{
			all += a[i];
		}
		if (all == 0)
		{
			continue;
		}
		yy++;
		int y[20000] = { 0 };
		int k = 0;
		for (int i = 0; i < 6; i++)
		{
			for (int j = 12; j >= 0; j--)
			{
				while (a[i] >= pow(2.0, j + 1))
				{
					a[i] -= pow(2.0, j);
					y[k] = pow(2.0, j)*(i + 1);
					k++;
				}
				if (a[i] == 1)
				{
					y[k] = 1 * (i + 1);
					k++;
					a[i]--;
				}
			}
		}
		int sum = 0;
		for (int i = 0; i < k; i++)
		{
			sum += y[i];
		}
		printf("Collection #%d:\n", yy);
		if (sum % 2 == 1)
		{
			printf("Can't be divided.\n\n");
			continue;
		}
		int dp[50000] = { 0 };
		for (int i = 0; i < k; i++)
		{
			for (int j = sum / 2; j >= y[i]; j--)
			{
				dp[j] = max(dp[j], dp[j - y[i]] + y[i]);
			}
		}
		if (dp[sum / 2] == sum - dp[sum / 2])
		{
			printf("Can be divided.\n\n");
		}
		else
		{
			printf("Can't be divided.\n\n");
		}
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章