1.20-e

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
Sample Input
3
Pirates
HDUacm
HDUACM
Sample Output
8
8
8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

定義一個變量如果是大寫就1小寫就0,注意如果開着大寫時按CapsLock就會變成小寫。

#include <iostream>
#include<cstring>
using namespace std;
int main()
{
	int n; cin >> n;
	for (int l = 0; l < n; l++)
	{
		char ch[105];
		cin >> ch; int t; t = 0;
		int k = strlen(ch);
		int i, h = 0;///////打開大寫就是1關閉就是0
		for (i = 0; i < k; i++)
		{
			if (h == 0)
				if (ch[i] <= 90 && ch[i] >= 65)
				{
					if (ch[i + 1] <= 90 && ch[i + 1] >= 65)
					{
						h = 1; t++;
					}
					else
					{
						h = 0; t++;
					}
				}
			if (h == 1)
			{
				if ((ch[i + 2] <= 122 && ch[i + 2] >= 97)&&( ch[i + 1] <= 122 && ch[i + 1] >= 97))
				{
					t++; h = 0;
				}
				if ((ch[i + 2] <= 90 && ch[i + 2] >= 65) && (ch[i + 1] <= 122 && ch[i + 1] >= 97))
				{
					t++;
				}
			}
			t++;
		}
		if (h == 1)t++;
		cout << t;
		cout << endl;
	}
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章