1.22-e

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.
Write a program to find and print the nth element in this sequence
Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.
Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
醜數就是它的是由若干個3,5,7,2相乘的到的

#include <iostream>
#include<cstring>
using namespace std;
int a[5849] ;
int min(int a, int b)
{
 return (a > b ? b : a);
}
void s()////先求出所有的醜數
{
 int p1, p2, p3, p4;
 a[1] = 1;
 p1 = p2 = p3 = p4 = 1;
 for (int i = 1; i <= 5842; i++)
 {
  a[i + 1] = min((min(a[p1] * 2, a[p2] * 3)), (min(a[p3] * 5, a[p4] * 7)));
  if (a[i + 1] == a[p1] * 2)p1++;
  if (a[i + 1] == a[p2] * 3)p2++;
  if (a[i + 1] == a[p3] * 5)p3++;
  if (a[i + 1] == a[p4] * 7)p4++;
 }
}
int main()
{
 int n;
 s();
 while (cin >> n && n != 0)
 {
  if (n % 100 != 11 && n % 10 == 1) 
  {
   cout << "The " << n << "st humble number is " << a[n] << "." << endl;
  }
  else
   if (n % 100 != 12 && n % 10 == 2)
  {
   cout << "The " << n << "nd humble number is " << a[n] << "." << endl;
  }
     else 
    if (n % 100 != 13 && n % 10 == 3)
     {
   cout << "The " << n << "rd humble number is " << a[n] << "." << endl;
     }
       else 
   cout << "The " << n << "th humble number is " << a[n] << "." << endl;
  
 }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章