hdu1087(第一天題F)

題目:Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each case, print the maximum according to rules, and one line one case.
Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0
Sample Output
4
10
3

解:一個一個看選不選,選的前提爲前面的要比這個都小
簡單dp
例:1 3 2,當檢索到第三個2的時候,那就檢查,發現1比2小
那麼我們就比較dp[1]+2和dp[3]的大小關係(dp[3]代表到第三個數時的最大值)且dp[3]也是可以選第三個數的
(就是要找到最後選的那個數是比現在這個數小的)
代碼:

#include<iostream>
#include<algorithm>
using namespace std;
int a[1050];
int dp[1050];
int main()
{
	int n;
	while (cin >> n)
	{
		memset(a, 0, sizeof(a));
		memset(dp, 0, sizeof(dp));
		if (n == 0)
		{
			break;
		}
		for (int i = 1; i <= n; i++)
		{
			cin >> a[i];
		}
		for (int i = 1; i <= n; i++)
		{
			for (int j = i; j >= 0; j--)
			{
				if (a[j]<a[i] && dp[j] + a[i]>dp[i])
				{
					dp[i] = dp[j] + a[i];
				}
			}
		}
		int k = dp[1];
		for (int i = 1; i <= n; i++)
		{
			if (k < dp[i])
			{
				k = dp[i];
			}
		}
		cout << k << endl;
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章