poj1426(第一天題I)

題目:
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

解:要求找出由1和0組成的數,可以用BFS方法搜索

第一位數只能是1 (01這就不是一個數了)
然後是10 11
相當於是二進制1<<1然後再加1或者0
1:1 2:10 3:11
即10=(2/2)*10+0 11=(2/2)*10+1
除以二可以找到未加0前的那截數,乘以10+0或者1就可以

代碼:

#include<iostream>
using namespace std;
int tk[500000];
int main()
{
	int n;
	while (cin >> n)
	{
		if (n == 0)
		{
			break;
		}
		memset(tk, 0, sizeof(tk));
		tk[1] = 1;
		int i = 2;
		while (1)
		{
			tk[i] = (tk[i / 2] * 10 + i % 2);
			if (tk[i] % n == 0)
			{
				break;
			}
			i++;
		}
		cout << tk[i] << endl;
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章