【HDUOJ1102】Constructing Roads(最小生成樹prim,簡單,別忘多組輸入謝謝)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30935    Accepted Submission(s): 11694


 

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

 

 

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

 

 

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

 

 

Sample Input


 

3 0 990 692 990 0 179 692 179 0 1 1 2

 

 

Sample Output


 

179

 

  

我永遠忘記多組輸入。。。。 

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <map>
#include <list>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <iostream>
#define mem(a) memset(a,0,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn = 1e3 + 10;
const double pi = atan(1.)*4;
typedef long long ll;
int G[maxn][maxn],vis[maxn],dis[maxn];
int n,q,a,b,sum;
int prim()
{
    mem(vis);
    vis[1] = 1;
    int pos = 1;
    sum = 0;
    for(int i=1;i<=n;i++)
        dis[i] = G[pos][i];
    for(int i=1;i<n;i++)
    {
        int minl=inf;
        for(int j=1;j <= n;j++)
        {
            if(!vis[j] && dis[j] < minl)
            {
                minl = dis[j];
                pos = j;
            }
        }
        sum += minl;
        vis[pos] = 1;
        for(int j=1;j <= n;j++)
            if(!vis[j] && G[pos][j] < dis[j])
                dis[j] = G[pos][j];
    }
    return sum;
}
int main()
{
    while(cin>>n)//???????????????????你沒事吧小老弟???別忘記多組輸入謝謝
    {
        memset(G,inf,sizeof(G));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                cin>>G[i][j];
        cin>>q;
        while(q--)
        {
            cin>>a>>b;
            G[a][b] = G[b][a] = 0;
        }
        prim();
        cout<<sum<<endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章