【HDUOJ1863】暢通工程(最小生成樹kruskal,簡單)

暢通工程

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 42164    Accepted Submission(s): 18853


 

Problem Description

省政府“暢通工程”的目標是使全省任何兩個村莊間都可以實現公路交通(但不一定有直接的公路相連,只要能間接通過公路可達即可)。經過調查評估,得到的統計表中列出了有可能建設公路的若干條道路的成本。現請你編寫程序,計算出全省暢通需要的最低成本。

 

 

Input

測試輸入包含若干測試用例。每個測試用例的第1行給出評估的道路條數 N、村莊數目M ( < 100 );隨後的 N 
行對應村莊間道路的成本,每行給出一對正整數,分別是兩個村莊的編號,以及此兩村莊間道路的成本(也是正整數)。爲簡單起見,村莊從1到M編號。當N爲0時,全部輸入結束,相應的結果不要輸出。

 

 

Output

對每個測試用例,在1行裏輸出全省暢通需要的最低成本。若統計數據不足以保證暢通,則輸出“?”。

 

 

Sample Input


 

3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100

 

 

Sample Output


 

3 ?



 

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <map>
#include <list>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <iostream>
#define mem(a) memset(a,0,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn = 1e2 + 10;
const double pi = atan(1.)*4;
typedef long long ll;
int n,m,ans;
int u[maxn],v[maxn],w[maxn],pre[maxn],r[maxn];
bool cmp(int x,int y)
{
    return w[x] < w[y];
}
int find(int x)
{
    return pre[x]==x ? x : pre[x] = find(pre[x]);
}
int kruskal()
{
    int cnt = 0;
    for(int i = 0;i < n;i++)    pre[i]=i;
    for(int i = 0;i < m;i++)    r[i] = i;
    sort(r,r+m,cmp);
    for(int i = 0;i < m;i++)
    {
        int e = r[i],x = find(u[e]),y = find(v[e]);
        if(x!=y)
        {
            ans += w[e];
            pre[x] = y;
            cnt++;
        }
    }
    if(cnt < n-1)   ans = 0;
    return ans;
}
int main()
{
    while(cin>>m>>n && m)
    {
        mem(u);
        mem(v);
        mem(w);
        mem(r);
        mem(pre);
        ans = 0;
        for(int i =0;i < m;i++)
            cin>>u[i]>>v[i]>>w[i];
        kruskal();
        if(!ans)    cout<<"?"<<endl;
        else    cout<<ans<<endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章