【HDUOJ1863】畅通工程(最小生成树kruskal,简单)

畅通工程

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 42164    Accepted Submission(s): 18853


 

Problem Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。

 

 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N 
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。

 

 

Output

对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。

 

 

Sample Input


 

3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100

 

 

Sample Output


 

3 ?



 

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <map>
#include <list>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <iostream>
#define mem(a) memset(a,0,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn = 1e2 + 10;
const double pi = atan(1.)*4;
typedef long long ll;
int n,m,ans;
int u[maxn],v[maxn],w[maxn],pre[maxn],r[maxn];
bool cmp(int x,int y)
{
    return w[x] < w[y];
}
int find(int x)
{
    return pre[x]==x ? x : pre[x] = find(pre[x]);
}
int kruskal()
{
    int cnt = 0;
    for(int i = 0;i < n;i++)    pre[i]=i;
    for(int i = 0;i < m;i++)    r[i] = i;
    sort(r,r+m,cmp);
    for(int i = 0;i < m;i++)
    {
        int e = r[i],x = find(u[e]),y = find(v[e]);
        if(x!=y)
        {
            ans += w[e];
            pre[x] = y;
            cnt++;
        }
    }
    if(cnt < n-1)   ans = 0;
    return ans;
}
int main()
{
    while(cin>>m>>n && m)
    {
        mem(u);
        mem(v);
        mem(w);
        mem(r);
        mem(pre);
        ans = 0;
        for(int i =0;i < m;i++)
            cin>>u[i]>>v[i]>>w[i];
        kruskal();
        if(!ans)    cout<<"?"<<endl;
        else    cout<<ans<<endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章