【HDUOJ1086】You can Solve a Geometry Problem too(計算線段交點個數,模板,簡單)

Problem Description

Many geometry(幾何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(線段), please output the number of all intersections(交點). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point. 

 

 

Input

Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed.

 

 

Output

For each case, print the number of intersections, and one line one case.

 

 

Sample Input


 

2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0

 

 

Sample Output


 

1 3


 

愉快的套了模板一把過了~~~這個模板是浮點型的,很棒棒 

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <map>
#include <list>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <iostream>
using namespace std;
const int N = 100010;
int mark[N];
typedef struct
{
    double x,y;
}Point;
struct stline
{
    Point a,b;
} line1,line2, p[N];

int dblcmp(double a,double b)
{
    if (fabs(a-b)<=1E-6) return 0;
    if (a>b) return 1;
    else return -1;
}
//***************點積判點是否在線段上***************
double dot(double x1,double y1,double x2,double y2) //點積
{
    return x1*x2+y1*y2;
}

int point_on_line(Point a,Point b,Point c) //求a點是不是在線段bc上,>0不在,=0與端點重合,<0在。
{
    return dblcmp(dot(b.x-a.x,b.y-a.y,c.x-a.x,c.y-a.y),0);
}
//**************************************************
double cross(double x1,double y1,double x2,double y2)
{
    return x1*y2-x2*y1;
}
double ab_cross_ac(Point a,Point b,Point c) //ab與ac的叉積
{
    return cross(b.x-a.x,b.y-a.y,c.x-a.x,c.y-a.y);
}
int ab_cross_cd(Point a,Point b,Point c,Point d) //求ab是否與cd相交,交點爲p。1規範相交,0交點是一線段的端點,-1不相交。
{
    double s1,s2,s3,s4;
    int d1,d2,d3,d4;
    Point p;
    d1=dblcmp(s1=ab_cross_ac(a,b,c),0);
    d2=dblcmp(s2=ab_cross_ac(a,b,d),0);
    d3=dblcmp(s3=ab_cross_ac(c,d,a),0);
    d4=dblcmp(s4=ab_cross_ac(c,d,b),0);
    
    //如果規範相交則求交點
    if ((d1^d2)==-2 && (d3^d4)==-2)
    {
        p.x=(c.x*s2-d.x*s1)/(s2-s1);
        p.y=(c.y*s2-d.y*s1)/(s2-s1);
        return 1;
    }
    
    //如果不規範相交
    if (d1==0 && point_on_line(c,a,b)<=0)
    {
        p=c;
        return 0;
    }
    if (d2==0 && point_on_line(d,a,b)<=0)
    {
        p=d;
        return 0;
    }
    if (d3==0 && point_on_line(a,c,d)<=0)
    {
        p=a;
        return 0;
    }
    if (d4==0 && point_on_line(b,c,d)<=0)
    {
        p=b;
        return 0;
    }
    //如果不相交
    return -1;
}
int main()
{
    int n;
    while(cin>>n&&n)
    {
        for(int i = 0;i < n;i++)
            cin>>p[i].a.x>>p[i].a.y>>p[i].b.x>>p[i].b.y;
        int cnt = 0;
        for(int i = 0;i <n;i++)
            for(int j = i+1;j < n;j++)
                    if(ab_cross_cd(p[i].a,p[i].b,p[j].a,p[j].b) != -1)  cnt++;
        cout<<cnt<<endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章