Practice Lab 3:多路由環境在CISCO路由器上的應用

 
 
R1#sh run
!
interface Loopback0
 ip address 137.20.1.17 255.255.255.240
interface Loopback1
 ip address 137.20.1.33 255.255.255.248
interface Loopback100
 ip address 1.1.1.1 255.255.255.255
interface FastEthernet0/0
 ip address 137.20.10.1 255.255.255.0
 duplex full
interface Serial2/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 no frame-relay inverse-arp
interface Serial2/0.2 point-to-point
 ip address 137.20.100.2 255.255.255.0
 ip ospf network point-to-point
 frame-relay interface-dlci 102  
interface Serial2/0.3 multipoint
 ip address 137.20.101.1 255.255.255.0
 frame-relay map ip 137.20.101.3 103 broadcast
 frame-relay map ip 137.20.101.5 105 broadcast
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 137.20.1.17 0.0.0.0 area 11
 network 137.20.1.33 0.0.0.0 area 11
 network 137.20.10.1 0.0.0.0 area 10
 network 137.20.100.2 0.0.0.0 area 0
 network 137.20.101.1 0.0.0.0 area 0
 neighbor 137.20.101.3
 neighbor 137.20.101.5
router bgp 2
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 137.20.100.1 remote-as 2
 neighbor 137.20.100.1 route-reflector-client
 neighbor 137.20.101.3 remote-as 2
 neighbor 137.20.101.5 remote-as 2
 neighbor 137.20.101.5 route-reflector-client
 no auto-summary
ip classless
no ip http server
end
 
校驗
R1#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback100
     137.20.0.0/16 is variably subnetted, 12 subnets, 4 masks
O IA    137.20.30.0/24 [110/65] via 137.20.101.3, 00:47:11, Serial2/0.3
O IA    137.20.20.0/24 [110/65] via 137.20.100.1, 00:47:11, Serial2/0.2
C       137.20.1.16/28 is directly connected, Loopback0
C       137.20.10.0/24 is directly connected, FastEthernet0/0
O E1    137.20.50.0/24 [110/164] via 137.20.101.5, 00:47:11, Serial2/0.3
O IA    137.20.40.0/24 [110/129] via 137.20.101.3, 00:47:11, Serial2/0.3
C       137.20.1.32/29 is directly connected, Loopback1
O IA    137.20.3.33/32 [110/65] via 137.20.101.3, 00:47:11, Serial2/0.3
O IA    137.20.3.65/32 [110/65] via 137.20.101.3, 00:47:11, Serial2/0.3
C       137.20.101.0/24 is directly connected, Serial2/0.3
C       137.20.100.0/24 is directly connected, Serial2/0.2
O IA    137.20.103.0/24 [110/128] via 137.20.101.3, 00:47:12, Serial2/0.3
     172.168.0.0/16 is variably subnetted, 2 subnets, 2 masks
B       172.168.2.0/24 [200/0] via 137.20.103.2, 00:19:12
O IA    172.168.32.1/32 [110/65] via 137.20.100.1, 00:47:12, Serial2/0.2
O E1 192.168.4.0/24 [110/164] via 137.20.101.5, 00:47:12, Serial2/0.3
     10.0.0.0/22 is subnetted, 1 subnets
O E1    10.1.0.0 [110/164] via 137.20.101.5, 00:40:42, Serial2/0.3
O E1 192.168.6.0/24 [110/164] via 137.20.101.5, 00:47:12, Serial2/0.3
O E1 192.168.2.0/24 [110/164] via 137.20.101.5, 00:47:12, Serial2/0.3
O E1 192.168.100.0/24 [110/164] via 137.20.101.5, 00:40:42, Serial2/0.3
O E1 160.0.0.0/4 [110/164] via 137.20.101.5, 00:40:42, Serial2/0.3
 
 
 

R2#sh run
!

interface Loopback0
 ip address 172.168.32.1 255.255.255.0
interface Loopback100
 ip address 1.1.2.2 255.255.255.255
interface FastEthernet0/0
 ip address 137.20.20.1 255.255.255.0
 duplex full
interface Serial2/0
 ip address 137.20.100.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-point
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 frame-relay de-group 1 201
 frame-relay map ip 137.20.100.2 201 broadcast
 no frame-relay inverse-arp

router ospf 1
 router-id 1.1.2.2
 log-adjacency-changes
 network 137.20.20.1 0.0.0.0 area 20
 network 137.20.100.1 0.0.0.0 area 0
 network 172.168.32.1 0.0.0.0 area 21
router bgp 2
 no synchronization
 bgp router-id 1.1.2.2
 bgp log-neighbor-changes
 neighbor 137.20.100.2 remote-as 2
 no auto-summary
ntp authentication-key 1 md5 13061E010803 7
ntp authenticate
ntp trusted-key 1
ntp master 2
ntp peer 137.20.101.3 key 1 source Loopback0
end
 
校驗
R2# sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.2.2 is directly connected, Loopback100
     137.20.0.0/16 is variably subnetted, 12 subnets, 2 masks
O IA    137.20.30.0/24 [110/129] via 137.20.100.2, 01:41:40, Serial2/0
C       137.20.20.0/24 is directly connected, FastEthernet0/0
O IA    137.20.1.17/32 [110/65] via 137.20.100.2, 01:41:40, Serial2/0
O IA    137.20.10.0/24 [110/65] via 137.20.100.2, 01:41:40, Serial2/0
O E1    137.20.50.0/24 [110/228] via 137.20.100.2, 01:41:40, Serial2/0
O IA    137.20.40.0/24 [110/193] via 137.20.100.2, 01:41:40, Serial2/0
O IA    137.20.1.33/32 [110/65] via 137.20.100.2, 01:41:40, Serial2/0
O IA    137.20.3.33/32 [110/129] via 137.20.100.2, 01:41:40, Serial2/0
O IA    137.20.3.65/32 [110/129] via 137.20.100.2, 01:41:40, Serial2/0
O       137.20.101.0/24 [110/128] via 137.20.100.2, 01:41:40, Serial2/0
C       137.20.100.0/24 is directly connected, Serial2/0
O IA    137.20.103.0/24 [110/192] via 137.20.100.2, 01:41:40, Serial2/0
     172.168.0.0/24 is subnetted, 2 subnets
B       172.168.2.0 [200/0] via 137.20.103.2, 00:19:15
C       172.168.32.0 is directly connected, Loopback0
O E1 192.168.4.0/24 [110/228] via 137.20.100.2, 00:48:27, Serial2/0
     10.0.0.0/22 is subnetted, 1 subnets
O E1    10.1.0.0 [110/228] via 137.20.100.2, 00:40:46, Serial2/0
O E1 192.168.6.0/24 [110/228] via 137.20.100.2, 00:48:27, Serial2/0
O E1 192.168.2.0/24 [110/228] via 137.20.100.2, 00:48:27, Serial2/0
O E1 192.168.100.0/24 [110/228] via 137.20.100.2, 00:40:46, Serial2/0
O E1 160.0.0.0/4 [110/228] via 137.20.100.2, 00:40:46, Serial2/0

R2# sh ntp s
Clock is synchronized, stratum 2, reference is 127.127.7.1
nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**24
reference time is CCB6AC8C.D0D2A2E6 (10:23:08.815 UTC Sat Nov 1 2008)
clock offset is 0.0000 msec, root delay is 0.00 msec
root dispersion is 0.02 msec, peer dispersion is 0.02 msec
 
 
R3#sh run


class-map match-all TCPTRAFFIC
  match access-group 101
class-map match-all IPTRAFFIC
  match access-group 100

policy-map TRAFFIC
  class IPTRAFFIC
   bandwidth percent 25
  class TCPTRAFFIC
   bandwidth percent 25
  class class-default
   bandwidth percent 10
interface Loopback0
 ip address 137.20.3.33 255.255.255.224
interface Loopback1
 ip address 137.20.3.65 255.255.255.224
interface Loopback100
 ip address 1.1.3.3 255.255.255.255
interface FastEthernet0/0
 ip address 137.20.30.1 255.255.255.0
 duplex full
interface Serial2/0
 ip address 137.20.101.3 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 frame-relay map ip 137.20.101.1 301 broadcast
 frame-relay map ip 137.20.101.5 301 broadcast
 no frame-relay inverse-arp
 service-policy output TRAFFIC
router ospf 1
 router-id 1.1.3.3
 log-adjacency-changes
 area 1 virtual-link 1.1.4.4
 network 137.20.3.33 0.0.0.0 area 31
 network 137.20.3.65 0.0.0.0 area 31
 network 137.20.30.1 0.0.0.0 area 30
 network 137.20.101.3 0.0.0.0 area 0
 network 137.20.103.1 0.0.0.0 area 1
 neighbor 137.20.103.2
router bgp 2
 no synchronization
 bgp router-id 1.1.3.3
 bgp log-neighbor-changes
 neighbor 137.20.101.1 remote-as 2
 neighbor 137.20.103.2 remote-as 1
 no auto-summary
ip classless
no ip http server

access-list 100 permit ip any any
access-list 101 permit tcp any any eq telnet
ntp authentication-key 1 md5 02050D480809 7
ntp authenticate
ntp trusted-key 1
ntp clock-period 17179863
ntp server 137.20.100.1 key 1 source Loopback0
end

校驗
R3# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.3.3 is directly connected, Loopback100
     137.20.0.0/16 is variably subnetted, 12 subnets, 3 masks
C       137.20.30.0/24 is directly connected, FastEthernet0/0
O IA    137.20.20.0/24 [110/129] via 137.20.101.1, 01:41:38, Serial2/0
O IA    137.20.1.17/32 [110/65] via 137.20.101.1, 01:41:38, Serial2/0
O IA    137.20.10.0/24 [110/65] via 137.20.101.1, 01:41:38, Serial2/0
O E1    137.20.50.0/24 [110/164] via 137.20.101.5, 01:41:28, Serial2/0
O IA    137.20.40.0/24 [110/65] via 137.20.103.2, 01:41:38, Serial2/1
O IA    137.20.1.33/32 [110/65] via 137.20.101.1, 01:41:38, Serial2/0
C       137.20.3.32/27 is directly connected, Loopback0
C       137.20.3.64/27 is directly connected, Loopback1
C       137.20.101.0/24 is directly connected, Serial2/0
O       137.20.100.0/24 [110/128] via 137.20.101.1, 01:41:38, Serial2/0
C       137.20.103.0/24 is directly connected, Serial2/1
     172.168.0.0/16 is variably subnetted, 2 subnets, 2 masks
B       172.168.2.0/24 [20/0] via 137.20.103.2, 00:19:23
O IA    172.168.32.1/32 [110/129] via 137.20.101.1, 01:41:38, Serial2/0
O E1 192.168.4.0/24 [110/164] via 137.20.101.5, 00:48:34, Serial2/0
     10.0.0.0/22 is subnetted, 1 subnets
O E1    10.1.0.0 [110/164] via 137.20.101.5, 00:40:53, Serial2/0
O E1 192.168.6.0/24 [110/164] via 137.20.101.5, 00:48:34, Serial2/0
O E1 192.168.2.0/24 [110/164] via 137.20.101.5, 00:48:34, Serial2/0
O E1 192.168.100.0/24 [110/164] via 137.20.101.5, 00:40:53, Serial2/0
O E1 160.0.0.0/4 [110/164] via 137.20.101.5, 00:40:53, Serial2/0
R3#sh ntp s
Clock is synchronized, stratum 3, reference is 137.20.100.1
nominal freq is 250.0000 Hz, actual freq is 250.0001 Hz, precision is 2**18
reference time is CCB6AB4C.8EB94211 (10:17:48.557 UTC Sat Nov 1 2008)
clock offset is -18.8688 msec, root delay is 515.72 msec
root dispersion is 86.00 msec, peer dispersion is 46.14 msec
R3#sh int s2/0
Serial2/0 is up, line protocol is up
 !
  Queueing strategy: Class-based queueing
  !
 
 

R4#sh run
!

interface Loopback100
 ip address 1.1.4.4 255.255.255.255
interface FastEthernet0/0
 ip address 137.20.40.1 255.255.255.0
 duplex full
interface Serial2/1
 ip address 137.20.103.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 frame-relay map ip 137.20.103.1 413 broadcast
 no frame-relay inverse-arp
router ospf 1
 router-id 1.1.4.4
 log-adjacency-changes
 area 1 virtual-link 1.1.3.3
 network 137.20.40.1 0.0.0.0 area 40
 network 137.20.103.2 0.0.0.0 area 1
 neighbor 137.20.103.1
router bgp 1
 no synchronization
 bgp router-id 1.1.4.4
 bgp log-neighbor-changes
 redistribute static route-map STATIC
 neighbor 137.20.103.1 remote-as 2
 no auto-summary
ip classless
ip route 172.168.1.0 255.255.255.0 Null0
ip route 172.168.2.0 255.255.255.0 Null0
no ip http server

access-list 1 permit 172.168.2.0 0.0.0.255
access-list 2 permit any
route-map STATIC permit 10
 match ip address 1
route-map STATIC deny 20
 match ip address 2

end
 
校驗
R4# sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.4.4 is directly connected, Loopback100
     137.20.0.0/16 is variably subnetted, 12 subnets, 2 masks
O IA    137.20.30.0/24 [110/65] via 137.20.103.1, 01:41:42, Serial2/1
O IA    137.20.20.0/24 [110/193] via 137.20.103.1, 01:41:42, Serial2/1
O IA    137.20.1.17/32 [110/129] via 137.20.103.1, 01:41:42, Serial2/1
O IA    137.20.10.0/24 [110/129] via 137.20.103.1, 01:41:42, Serial2/1
O E1    137.20.50.0/24 [110/228] via 137.20.103.1, 01:41:32, Serial2/1
C       137.20.40.0/24 is directly connected, FastEthernet0/0
O IA    137.20.1.33/32 [110/129] via 137.20.103.1, 01:41:42, Serial2/1
O IA    137.20.3.33/32 [110/65] via 137.20.103.1, 01:41:42, Serial2/1
O IA    137.20.3.65/32 [110/65] via 137.20.103.1, 01:41:42, Serial2/1
O       137.20.101.0/24 [110/128] via 137.20.103.1, 01:41:42, Serial2/1
O       137.20.100.0/24 [110/192] via 137.20.103.1, 01:41:42, Serial2/1
C       137.20.103.0/24 is directly connected, Serial2/1
     172.168.0.0/16 is variably subnetted, 3 subnets, 2 masks
S       172.168.1.0/24 is directly connected, Null0
S       172.168.2.0/24 is directly connected, Null0
O IA    172.168.32.1/32 [110/193] via 137.20.103.1, 01:41:42, Serial2/1
O E1 192.168.4.0/24 [110/228] via 137.20.103.1, 00:48:38, Serial2/1
     10.0.0.0/22 is subnetted, 1 subnets
O E1    10.1.0.0 [110/228] via 137.20.103.1, 00:40:57, Serial2/1
O E1 192.168.6.0/24 [110/228] via 137.20.103.1, 00:48:38, Serial2/1
O E1 192.168.2.0/24 [110/228] via 137.20.103.1, 00:48:38, Serial2/1
O E1 192.168.100.0/24 [110/228] via 137.20.103.1, 00:40:57, Serial2/1
O E1 160.0.0.0/4 [110/228] via 137.20.103.1, 00:40:57, Serial2/1
 
 
 
R5#sh run
interface Loopback100
 ip address 1.1.5.5 255.255.255.255
interface FastEthernet0/0
 ip address 137.20.50.1 255.255.255.0
 ip access-group 100 in
 duplex full
interface Serial2/0
 ip address 137.20.101.5 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 frame-relay map ip 137.20.101.1 501 broadcast
 frame-relay map ip 137.20.101.3 501 broadcast
 no frame-relay inverse-arp

router eigrp 100
 redistribute ospf 1 metric 10000 100 255 1 1500
 network 137.20.50.1 0.0.0.0
 no auto-summary
router ospf 1
 router-id 1.1.5.5
 log-adjacency-changes
 redistribute eigrp 100 metric 100 metric-type 1 subnets
 network 137.20.101.5 0.0.0.0 area 0
 distribute-list 10 out
router bgp 2
 no synchronization
 bgp router-id 1.1.5.5
 bgp log-neighbor-changes
 neighbor 137.20.50.7 remote-as 3
 neighbor 137.20.101.1 remote-as 2
 no auto-summary
ip classless
no ip http server

access-list 1 deny   192.168.100.1
access-list 1 permit any
access-list 10 deny   192.168.1.0 0.0.254.0
access-list 10 permit any
access-list 100 deny   icmp host 137.20.50.6 host 137.20.10.1
access-list 100 permit ip any any

end
 
校驗
R5# sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.5.5 is directly connected, Loopback100
     137.20.0.0/16 is variably subnetted, 12 subnets, 2 masks
O IA    137.20.30.0/24 [110/65] via 137.20.101.3, 00:51:36, Serial2/0
O IA    137.20.20.0/24 [110/129] via 137.20.101.1, 00:51:36, Serial2/0
O IA    137.20.1.17/32 [110/65] via 137.20.101.1, 00:51:36, Serial2/0
O IA    137.20.10.0/24 [110/65] via 137.20.101.1, 00:51:36, Serial2/0
C       137.20.50.0/24 is directly connected, FastEthernet0/0
O IA    137.20.40.0/24 [110/129] via 137.20.101.3, 00:51:36, Serial2/0
O IA    137.20.1.33/32 [110/65] via 137.20.101.1, 00:51:36, Serial2/0
O IA    137.20.3.33/32 [110/65] via 137.20.101.3, 00:51:36, Serial2/0
O IA    137.20.3.65/32 [110/65] via 137.20.101.3, 00:51:36, Serial2/0
C       137.20.101.0/24 is directly connected, Serial2/0
O       137.20.100.0/24 [110/128] via 137.20.101.1, 00:51:37, Serial2/0
O IA    137.20.103.0/24 [110/128] via 137.20.101.3, 00:51:37, Serial2/0
     172.168.0.0/16 is variably subnetted, 2 subnets, 2 masks
B       172.168.2.0/24 [200/0] via 137.20.103.2, 00:19:32
O IA    172.168.32.1/32 [110/129] via 137.20.101.1, 00:51:37, Serial2/0
D EX 192.168.4.0/24 [170/284160] via 137.20.50.6, 00:48:46, FastEthernet0/0
D EX 192.168.5.0/24 [170/284160] via 137.20.50.6, 00:48:46, FastEthernet0/0
     10.0.0.0/22 is subnetted, 1 subnets
D       10.1.0.0 [90/284160] via 137.20.50.7, 00:41:04, FastEthernet0/0
D EX 192.168.6.0/24 [170/284160] via 137.20.50.6, 00:48:46, FastEthernet0/0
D EX 192.168.1.0/24 [170/284160] via 137.20.50.6, 00:48:46, FastEthernet0/0
D EX 192.168.2.0/24 [170/284160] via 137.20.50.6, 00:48:46, FastEthernet0/0
D EX 192.168.100.0/24 [170/284160] via 137.20.50.7, 00:41:04, FastEthernet0/0
D EX 192.168.3.0/24 [170/284160] via 137.20.50.6, 00:48:46, FastEthernet0/0
D    160.0.0.0/4 [90/156160] via 137.20.50.7, 00:41:04, FastEthernet0/0
 
 
R6#sh run
!
interface Loopback100
 ip address 1.1.6.6 255.255.255.255
interface FastEthernet0/0
 ip address 137.20.50.6 255.255.255.0
 duplex full

router eigrp 100
 redistribute static metric 10000 100 255 1 1500
 network 137.20.50.6 0.0.0.0
 no auto-summary
ip classless
ip route 192.168.1.0 255.255.255.0 Null0
ip route 192.168.2.0 255.255.255.0 Null0
ip route 192.168.3.0 255.255.255.0 Null0
ip route 192.168.4.0 255.255.255.0 Null0
ip route 192.168.5.0 255.255.255.0 Null0
ip route 192.168.6.0 255.255.255.0 Null0
no ip http server
end
 
校驗
R6#  sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.6.6 is directly connected, Loopback100
     137.20.0.0/16 is variably subnetted, 12 subnets, 2 masks
D EX    137.20.30.0/24 [170/284160] via 137.20.50.1, 00:48:48, FastEthernet0/0
D EX    137.20.20.0/24 [170/284160] via 137.20.50.1, 00:48:48, FastEthernet0/0
D EX    137.20.1.17/32 [170/284160] via 137.20.50.1, 00:48:48, FastEthernet0/0
D EX    137.20.10.0/24 [170/284160] via 137.20.50.1, 00:48:48, FastEthernet0/0
C       137.20.50.0/24 is directly connected, FastEthernet0/0
D EX    137.20.40.0/24 [170/284160] via 137.20.50.1, 00:48:48, FastEthernet0/0
D EX    137.20.1.33/32 [170/284160] via 137.20.50.1, 00:48:48, FastEthernet0/0
D EX    137.20.3.33/32 [170/284160] via 137.20.50.1, 00:48:48, FastEthernet0/0
D EX    137.20.3.65/32 [170/284160] via 137.20.50.1, 00:48:48, FastEthernet0/0
D EX    137.20.101.0/24
           [170/284160] via 137.20.50.1, 00:48:48, FastEthernet0/0
D EX    137.20.100.0/24
           [170/284160] via 137.20.50.1, 00:48:49, FastEthernet0/0
D EX    137.20.103.0/24
           [170/284160] via 137.20.50.1, 00:48:49, FastEthernet0/0
     172.168.0.0/32 is subnetted, 1 subnets
D EX    172.168.32.1 [170/284160] via 137.20.50.1, 00:48:49, FastEthernet0/0
S    192.168.4.0/24 is directly connected, Null0
S    192.168.5.0/24 is directly connected, Null0
     10.0.0.0/22 is subnetted, 1 subnets
D       10.1.0.0 [90/284160] via 137.20.50.7, 00:41:10, FastEthernet0/0
S    192.168.6.0/24 is directly connected, Null0
S    192.168.1.0/24 is directly connected, Null0
S    192.168.2.0/24 is directly connected, Null0
D EX 192.168.100.0/24 [170/284160] via 137.20.50.7, 00:41:10, FastEthernet0/0
S    192.168.3.0/24 is directly connected, Null0
D    160.0.0.0/4 [90/156160] via 137.20.50.7, 00:41:10, FastEthernet0/0
 

R7#sh run
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
interface Loopback1
 ip address 10.1.2.1 255.255.255.0
interface Loopback2
 ip address 160.10.10.1 255.255.255.0
interface Loopback3
 ip address 161.10.10.1 255.255.255.0
interface Loopback4
 ip address 170.10.10.1 255.255.255.0
interface Loopback100
 ip address 1.1.7.7 255.255.255.255
interface FastEthernet0/0
 ip address 137.20.50.7 255.255.255.0
 ip summary-address eigrp 100 160.0.0.0 240.0.0.0 5
 ip summary-address eigrp 100 10.1.0.0 255.255.252.0 5
 duplex full
interface FastEthernet1/0
 ip address 192.168.100.1 255.255.255.0
 duplex full
router eigrp 100
 redistribute rip metric 10000 100 255 1 1500
 network 137.20.50.7 0.0.0.0
 network 160.10.10.1 0.0.0.0
 network 161.10.10.1 0.0.0.0
 network 170.10.10.1 0.0.0.0
 no auto-summary
router rip
 version 2
 network 10.0.0.0
 network 192.168.100.0
 no auto-summary
router bgp 3
 no synchronization
 bgp router-id 1.1.7.7
 bgp log-neighbor-changes
 neighbor 137.20.50.1 remote-as 2
 no auto-summary
end
 
校驗
R7# sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     170.10.0.0/24 is subnetted, 1 subnets
C       170.10.10.0 is directly connected, Loopback4
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.7.7 is directly connected, Loopback100
     137.20.0.0/16 is variably subnetted, 12 subnets, 2 masks
D EX    137.20.30.0/24 [170/284160] via 137.20.50.1, 00:41:13, FastEthernet0/0
D EX    137.20.20.0/24 [170/284160] via 137.20.50.1, 00:41:13, FastEthernet0/0
D EX    137.20.1.17/32 [170/284160] via 137.20.50.1, 00:41:13, FastEthernet0/0
D EX    137.20.10.0/24 [170/284160] via 137.20.50.1, 00:41:13, FastEthernet0/0
C       137.20.50.0/24 is directly connected, FastEthernet0/0
D EX    137.20.40.0/24 [170/284160] via 137.20.50.1, 00:41:13, FastEthernet0/0
D EX    137.20.1.33/32 [170/284160] via 137.20.50.1, 00:41:13, FastEthernet0/0
D EX    137.20.3.33/32 [170/284160] via 137.20.50.1, 00:41:13, FastEthernet0/0
D EX    137.20.3.65/32 [170/284160] via 137.20.50.1, 00:41:14, FastEthernet0/0
D EX    137.20.101.0/24
           [170/284160] via 137.20.50.1, 00:41:14, FastEthernet0/0
D EX    137.20.100.0/24
           [170/284160] via 137.20.50.1, 00:41:14, FastEthernet0/0
D EX    137.20.103.0/24
           [170/284160] via 137.20.50.1, 00:41:14, FastEthernet0/0
     172.168.0.0/16 is variably subnetted, 2 subnets, 2 masks
B       172.168.2.0/24 [20/0] via 137.20.50.1, 00:04:01
D EX    172.168.32.1/32
           [170/284160] via 137.20.50.1, 00:41:14, FastEthernet0/0
D EX 192.168.4.0/24 [170/284160] via 137.20.50.6, 00:41:14, FastEthernet0/0
D EX 192.168.5.0/24 [170/284160] via 137.20.50.6, 00:41:14, FastEthernet0/0
     160.10.0.0/24 is subnetted, 1 subnets
C       160.10.10.0 is directly connected, Loopback2
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.1.2.0/24 is directly connected, Loopback1
C       10.1.1.0/24 is directly connected, Loopback0
D       10.1.0.0/22 is a summary, 02:32:09, Null0
D EX 192.168.6.0/24 [170/284160] via 137.20.50.6, 00:41:14, FastEthernet0/0
     161.10.0.0/24 is subnetted, 1 subnets
C       161.10.10.0 is directly connected, Loopback3
D EX 192.168.1.0/24 [170/284160] via 137.20.50.6, 00:41:14, FastEthernet0/0
D EX 192.168.2.0/24 [170/284160] via 137.20.50.6, 00:41:14, FastEthernet0/0
C    192.168.100.0/24 is directly connected, FastEthernet1/0
D EX 192.168.3.0/24 [170/284160] via 137.20.50.6, 00:41:14, FastEthernet0/0
D    160.0.0.0/4 is a summary, 00:41:19, Null0
R7#
 
交換機VLAN環境
SWITCH#sh vlan-s brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/0, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                Fa0/15, Fa1/0, Fa1/1, Fa1/2
                                                Fa1/3, Fa1/4, Fa1/5, Fa1/6
                                                Fa1/7, Fa1/8, Fa1/9, Fa1/10
                                                Fa1/11, Fa1/12, Fa1/13, Fa1/14
                                                Fa1/15
10   VLAN0010                         active    Fa0/1
20   VLAN0020                         active    Fa0/2
30   VLAN0030                         active    Fa0/3
40   VLAN0040                         active    Fa0/4
567  VLAN0567                         active    Fa0/5, Fa0/6, Fa0/7
1002 fddi-default                     active   
1003 token-ring-default               active   
1004 fddinet-default                  active   
1005 trnet-default                    active   
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章