【PAT 甲級】1058 A+B in Hogwarts (20 分)

1058 A+B in Hogwarts (20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

我的思路

主要就是讀懂英文,然後暴力模擬。

“Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle” 就是17個銀西克兌一個加隆,29個納特兌一個西克。

 

我的代碼

#include <cstdio>
int main()
{
	int g1,g2,s1,s2,k1,k2;
	int k,s,g;
	scanf("%d.%d.%d %d.%d.%d", &g1,&s1,&k1,&g2,&s2,&k2);
	k = (k1+k2)%29;
	s = ((k1+k2)/29 + s1 + s2)%17;
	g = ((k1+k2)/29 + s1 + s2)/17 + g1 + g2;
	printf("%d.%d.%d",g,s,k);
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章