【PAT 甲級】1031 Hello World for U (20 分)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

我的思路

字符串讀入,找規律,然後直接輸出。

我這裏cin和printf混用了,可能不太好。用gets(s)測試OJ卻報錯。

 

我的代碼

#include <cstdio>
#include <string>
#include <iostream>
using namespace std;
int main()
{
	int n1=3, n2=2, N;
	string s;
	cin >> s;
	N = s.length();
	
	//求n1、n2、n3 
	while(n2<n1)
	{
		n2++;
		n1 = (N+2-n2)/2;
	}
	if ((n1*2+n2-2)!=N)
	{
		n2++;
	}

	//printf("%d %d\n", n1, n2);	
	//輸出 
	for (int i=0; i<n1-1; i++)
	{
		printf("%c",s[i]);
		for (int g=1; g<=n2-2; g++)
		{
			printf(" ");
		}
		printf("%c\n",s[N-1-i]);

	}
	for (int i=1; i<=n2; i++)
	{
		printf("%c",s[n1-1]);
		n1++;
	}
	return 0;
 } 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章