【PAT 甲級】1011 World Cup Betting (20)

1011 World Cup Betting (20)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and Lfor lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

 

我的思路

雖然英文題目一開始沒看懂,但是看數據和公式就明白是怎麼個套路了。

找出每行最大的數,並記錄該數的下標 0/1/2。

 

注意事項

關於奇怪的保留兩位小數.2f自動四捨五入,查看了這篇文章,決定採用+0.001的方法。

 

我的代碼

一開始直接就想着找最大值,然後用if else記錄對應W T L。

#include <cstdio>

//找出三個數中最大值的函數 
double max(double a, double b, double c)
{
	double M;
	if (a>=b)
	{
		if (a>=c)
		{
			printf("W ");
			M = a;
		} else {
			printf("L ");
			M = c;
		}
	} else {
		if (b>=c)
		{
			printf("T ");
			M = b;
		} else {
			printf("L ");
			M = c;	
		}
	}
	return M;
}

//主函數 
int main()
{
	double W, T, L, sum=1.0;
	for (int i=1; i<=3; i++)
	{
		scanf ("%lf %lf %lf", &W, &T, &L);
		sum *= max(W,T,L);
	}
	sum = (sum*0.65-1.0)*2.0 + 0.001;  //加0.001便於四捨五入 
	printf("%.2lf", sum);
	return 0;
} 

後來看了《算法筆記》,確實存成數組,用下標找會更簡便:

#include <cstdio>

int main()
{
	double t, max, sum=1.0;
	int j, flag;
	char n[]={'W','T','L'};
	for (int i=0; i<3; i++)
	{
		max = 0.0;
		for (j=0; j<3; j++)
		{
		    scanf ("%lf", &t);
			if (t>max)
			{
				max = t;
				flag = j;
			}	
		}
		sum *= max;
		printf("%c ", n[flag]);
	}
	sum = (sum*0.65-1.0)*2.0 + 0.001;  //加0.001便於四捨五入 
	printf("%.2lf", sum);
	return 0;
} 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章