【PAT 甲級】1019 General Palindromic Number (20 分)

1019 General Palindromic Number (20 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

我的思路

雖然一開始一堆英文我也不認識,但是看測試數據,大概猜出來要把N(十進制數)轉換成 b進制數,然後判斷是不是迴文數,即是不是對稱的。

另外,0<N≤10​9​​ ,2≤b≤10​9 ,我並不能判斷出用來存放轉換後的數據的數組的大小,所以就隨便試了,反正例子過了。​​

 

我的代碼

#include <cstdio>
int main()
{
	int N, b, i=0;
	int a[1000]={0};
	bool flag = true;
	scanf("%d %d", &N, &b);
	
	if (N==0)
	{  //如果N是0,直接輸出並結束。 
		printf("Yes\n0"); 
		return 0;
	} 
	
	//進制轉換 
	while(N!=0)
	{
		a[i] = N%b;
		N = N/b;
		i++;
	}
	
	//判斷是否對稱
	int t;
	if (i%2==0)
	{
		t = i;  //偶數個 
	} else {
		t = i-1;  //奇數個
	} 
	for (int j=0; j<t/2; j++)
	{
		if(a[i-1-j]!=a[j])
		{  //不對稱 
			flag = false;
			break;
		}
	}
	
	//輸出
	if (flag) printf("Yes\n");
		else printf("No\n");
		
	for(int j=i-1; j>=0; j--)
	{
		printf("%d", a[j]);
		if (j!=0) printf(" ");
	}
	
	return 0;
 } 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章