HDU-2476 String Painter(區間dp)

HDU-2476

問題描述

There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

Input

Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.

Output

A single line contains one integer representing the answer.

Sample Input

zzzzzfzzzzz
abcdefedcba
abababababab
cdcdcdcdcdcd

Sample Output

6
7

題意

給你兩個長度相等的a串和b串,問最少需要幾次將a串變成b串。

個人理解

我一開始用直接塗色的方式塗,一直塗不對,反正就是塗不對。
網上題解的做法都是先算出b串從空串塗得所需要的步數,然後再算出a串塗成b串需要的步數。
算b串從空串塗得所需要的步數很簡單,一個區間dp的固定格式。
算出a串塗成b串需要的步數就需要分兩種情況了:

  1. 當前兩個位置的顏色相同,不需要塗色,直接ans[i] = ans[i-1]
  2. 當前兩個位置的顏色不相同,那麼就遍歷每個位置,中間的當作空串處理,遞推關係如下:
    ans[i]=min(ans[i],ans[k]+dp[k+1][j])(1kj1)ans[i] = min(ans[i],ans[k]+dp[k+1][j])(1 \leq k \leq j-1)

代碼

#include <bits/stdc++.h>
using namespace std;
const int maxn = 110;

char a[maxn],b[maxn];
int len;
int dp[maxn][maxn];
int ans[maxn];

int main(){
	while(scanf("%s%s",a+1,b+1)!=EOF){
		memset(dp,0,sizeof(dp));
		len = strlen(a+1);
		for(int i = 1;i<=len;i++){
			dp[i][i] = 1;
		}
		for(int l = 2;l<=len;l++){
			for(int i = 1;i+l-1<=len;i++){
				int j = i+l-1;
				dp[i][j] = dp[i+1][j]+1;
				for(int k = i+1;k<=j;k++){
					dp[i][j] = min(dp[i][j],dp[i+1][k]+dp[k+1][j]+(b[i]!=b[k]));
				}
			}
		}
		for(int i = 1;i<=len;i++){
			ans[i] = dp[1][i];
		}
		for(int i = 1;i<=len;i++){
			if(a[i] == b[i]){
				ans[i] = ans[i-1];
			}
			for(int k = 1;k<i;k++){
				ans[i] = min(ans[i],ans[k]+dp[k+1][i]);
			}
		}
//		for(int i = 1;i<=len;i++){
//			printf("%d ",ans[i]);
//		}
//		putchar('\n');
		printf("%d\n",ans[len]);
	}	
	
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章