Spreading the Wealth UVA - 11300 思维+中位数

Problem
A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input
There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output
For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input
3
100
100
100
4
1
2
5
4
Sample Output
0
4

题意:给出n个人,每个人有一些金币,可以给一些金币左边或者右边的人,最终使得每个人有相同的金币,问最小的转移金币是多少?

思路:
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e6+100;
ll sum,a[maxn],c[maxn],ans,x1;
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		sum=ans=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%lld",&a[i]);
			sum+=a[i];
		}
		sum/=n;
		c[0]=0;
		for(int i=1;i<n;i++) c[i]=c[i-1]+a[i]-sum;
		sort(c,c+n);
		if(n&1) x1=c[n/2];
		else x1=(c[n/2]+c[n/2-1])/2;
		for(int i=0;i<n;i++) ans+=abs(c[i]-x1);
		printf("%lld\n",ans);
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章