POJ - 1654 Area (計算幾何 叉積 求多邊形面積)

Area

 

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input

4
5
825
6725
6244865

Sample Output

0
0
0.5
2

題目鏈接:http://poj.org/problem?id=1654

題目大意:8,2,6,4 分別表示北,南,東,西, 9,7,3,1 分別表示東北,西北,東南,西南, 5表示結束動,起點(0,0),按照給的序列從起點開始畫圖,保證沒有交叉的線,求所畫圖的面積

思路:用叉積求面積

代碼:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
#define ll long long
const int N=1000005;
char ss[N];
struct node
{
    ll x,y;
};
ll go[][2]={-1,-1,0,-1,1,-1,-1,0,0,0,1,0,-1,1,0,1,1,1};
ll cross(node a,node b,node c)
{
    return (b.x-a.x)*(c.y-a.y)-(b.y-a.y)*(c.x-a.x);
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",ss);
        int n=strlen(ss);
        ll ans=0;
        node a,b,c;
        a.x=0,a.y=0;
        int k=ss[0]-'0'-1;
        b.x=go[k][0],b.y=go[k][1];
        for(int i=1;i<n;i++)
        {
            k=ss[i]-'0'-1;
            c.x=b.x+go[k][0];
            c.y=b.y+go[k][1];
            ans+=cross(a,b,c);
            b=c;
        }
        ans=fabs(ans);
        if(ans%2) printf("%lld.5\n",ans/2);
        else printf("%lld\n",ans/2);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章