POJ - 1265 Area (計算幾何 Pick定理 叉積)

Area

 

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area.



Figure 1: Example area.


You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself.

Input

The first line contains the number of scenarios.
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units.

Output

The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

題目鏈接:http://poj.org/problem?id=1265

題目大意:給n個向量,求向量在網格上構成的多邊形的內部的網格點數,多邊形邊上的網格點數,和多邊形的面積

思路:向量上的網格點數等於gcd( dx,dy) ,如果dx==0或dy==0 那麼網格點數就等於dy或dx, 用叉積求出多邊形面積S

根據Pick定理:S = i + (d/2) -1 ,  其中S是面積,i是多邊形內部的網格點數, d是多邊形邊上的網格點數

可以推得:i = ( 2*S + 2 - d) /2

代碼:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
const int N=100005;
struct node
{
    int x,y;
};
int gcd(int x,int y)
{
    if(x==0) return y;
    else if(y==0) return x;
    return __gcd(x,y);
}
int cross(node a,node b,node c)
{
    return (b.x-a.x)*(c.y-a.y)-(b.y-a.y)*(c.x-a.x);
}
int main()
{
    int t,T=1;
    scanf("%d",&t);
    while(t--)
    {
        node a,b,c;
        int n,dx,dy,ans=0,s1,s2=0;
        scanf("%d",&n);
        a.x=0,a.y=0;
        scanf("%d%d",&b.x,&b.y);
        s2+=gcd(abs(b.x),abs(b.y));
        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&dx,&dy);
            c.x=b.x+dx,c.y=b.y+dy;
            s2+=gcd(abs(dx),abs(dy));
            ans+=cross(a,b,c);
            b=c;
        }
        ans=abs(ans);
        s1=ans+2-s2;
        printf("Scenario #%d:\n%d %d %.1f\n",T++,s1/2,s2,ans/2.0);
        if(t) printf("\n");
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章