River Hopscotch POJ - 3258 (二分搜索枚舉判斷)

題目:

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, Lunits away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

題意:

給你三個數字,L,N,M,L代表河流的長度爲L(起點是0,重點是L),N代表有N塊石頭,M代表要移除的石頭的塊數;

下面的N個數字代表每一塊石頭距離起點0的距離;

讓你求出來移除M塊石頭後要跳躍到終點的最小的跳躍距離;

思路:

對於這一道題,我們可以用二分法來枚舉所有的可以跳躍的最小的距離,當移除的石頭塊數是M時就是結果;

代碼如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int N=50010;
const int inf=1e9;

int l,n,m;
int a[N];
int high,low;

int main()
{
    while(~scanf("%d%d%d",&l,&n,&m))
    {
        a[0]=0;//起點;
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        a[n+1]=l;//終點;
        sort(a,a+n+1);
        high=l;
        low=inf;
        for(int i=1; i<=n+1; i++)
            low=min(a[i]-a[i-1],low);//最小的石頭之間的距離
                                    //即,可以調越的最小的距離;
        while(low<high)//枚舉跳躍的距離,找出最小的合適解;
        {
            int sum=0;//兩點之間的跳躍距離;
            int ss=0;//刪除的石頭數;
            int mid=(low+high)/2;
            for(int i=1; i<=n; i++)
            {
                if(sum+a[i]-a[i-1]<=mid)//小於最兇啊的跳躍值,那麼就可以把這塊石頭去除;
                {
                    ss++;//刪除的石頭的塊數;
                    sum=sum+(a[i]-a[i-1]);//現在跳的距離;
                }
                else//否則就只能跳在這塊石頭上,那麼已經跳躍的距離就是0;
                    sum=0;
            }
            if(ss<=m)//移除的石頭數量小於要求值,那麼就擴大跳躍的距離;
                low=mid+1;
            else//否則縮小跳躍的距離;
                high=mid;
        }
        printf("%d\n",low);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章