River Hopscotch POJ - 3258 (二分搜索枚举判断)

题目:

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, Lunits away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题意:

给你三个数字,L,N,M,L代表河流的长度为L(起点是0,重点是L),N代表有N块石头,M代表要移除的石头的块数;

下面的N个数字代表每一块石头距离起点0的距离;

让你求出来移除M块石头后要跳跃到终点的最小的跳跃距离;

思路:

对于这一道题,我们可以用二分法来枚举所有的可以跳跃的最小的距离,当移除的石头块数是M时就是结果;

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int N=50010;
const int inf=1e9;

int l,n,m;
int a[N];
int high,low;

int main()
{
    while(~scanf("%d%d%d",&l,&n,&m))
    {
        a[0]=0;//起点;
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        a[n+1]=l;//终点;
        sort(a,a+n+1);
        high=l;
        low=inf;
        for(int i=1; i<=n+1; i++)
            low=min(a[i]-a[i-1],low);//最小的石头之间的距离
                                    //即,可以调越的最小的距离;
        while(low<high)//枚举跳跃的距离,找出最小的合适解;
        {
            int sum=0;//两点之间的跳跃距离;
            int ss=0;//删除的石头数;
            int mid=(low+high)/2;
            for(int i=1; i<=n; i++)
            {
                if(sum+a[i]-a[i-1]<=mid)//小于最凶啊的跳跃值,那么就可以把这块石头去除;
                {
                    ss++;//删除的石头的块数;
                    sum=sum+(a[i]-a[i-1]);//现在跳的距离;
                }
                else//否则就只能跳在这块石头上,那么已经跳跃的距离就是0;
                    sum=0;
            }
            if(ss<=m)//移除的石头数量小于要求值,那么就扩大跳跃的距离;
                low=mid+1;
            else//否则缩小跳跃的距离;
                high=mid;
        }
        printf("%d\n",low);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章