POJ3107Godfather

題目鏈接

Godfather

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 11238   Accepted: 3946

Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair aibi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input

6
1 2
2 3
2 5
3 4
3 6

Sample Output

2 3

 求樹的重心。就是去除這個點,留下的塊中節點數最多的塊,與去除其他節點相比,是最少的。

這根本不是樹形dp吧。。。就一模擬。。。

不過事實證明,流輸入輸出優化後也沒有scanf,printf快。

一個弱智錯誤還卡了我半天。。。

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
#include <cstring>
#define ms(a,b) memset(a,b,sizeof(a)) 
using namespace std;
const int N=5e4+10;
int h[N<<1],nx[N<<1],to[N<<1];
int ans[N],n,tot;
void add(int u,int v)
{
	to[++tot]=v;
	nx[tot]=h[u];
	h[u]=tot;
//	cout<<u<<' '<<to[tot]<<endl;
}
int dfs(int x,int fa)
{
	int sum=1;
	ans[x]=0;
	for(int i=h[x];i;i=nx[i])
	{
		int v=to[i];
		if(v==fa) continue;
		int t=dfs(v,x);
//		cout<<v<<' '<<t<<endl;
		ans[x]=max(ans[x],t);
		sum+=t;
	}
	ans[x]=max(ans[x],n-sum);
	return sum;
}
int main()
{
//	ios::sync_with_stdio(false);
//	cin.tie(0);
//	cout.tie(0);
	while(~scanf("%d",&n))
	{
		int x,y;
		ms(h,0);
		tot=0;
		for(int i=1;i<n;i++)
		{
			scanf("%d%d",&x,&y);
			add(x,y);
			add(y,x);
		}
		dfs(1,0);
		int res=n;
		for(int i=1;i<=n;i++)
			res=min(ans[i],res);//這裏的ans[i]寫成了ans[x] 
		for(int i=1;i<=n;i++)
			if(res==ans[i])
				printf("%d ",i);
		printf("\n");
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章