poj_2418 Hardwood Species (字典序Trie树)

又是一道典型的Trie树应用题,有了Trie树的基本知识,写起来就非常容易了~~

【题目描述】

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. 
America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States. 

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber such as 2x4s and 2x6s, with some limited decorative applications. 

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

【题目要求】

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.

【样例输入】

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

【样例输出】

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

typedef struct node //儿子兄弟表示法
{
    char c;
    char s[50];
    long int num;
    struct node* fChild;
    struct node* rCousin;
}* triTree;

triTree newTree(char ch)
{
    triTree p=(triTree) malloc(sizeof(struct node));
    p->c=ch;
    p->num=0;
    p->fChild=NULL;
    p->rCousin=NULL;
    return p;
}

void setTree(triTree t, long int* total) //建立一棵字典序Trie树
{
    char s[50];
    while (gets(s)!=NULL) //需要用gets,因为树名中可能有空格
    {
        (*total)++; //注意*和++的优先级顺序
        int i,len=strlen(s);
        triTree x=t,y;
        for (i=0;i<len;i++)
        {
            y=x->fChild;
            if ((y==NULL)||((y!=NULL)&&(y->c > s[i]))) //当前结点没有长子或者长子字符大于待查字符时,剩余字符串按长子树插入
            {
                int k;
                triTree z=newTree(s[i]);

                x->fChild=z; x=z;
                for (k=i+1;k<len;k++){x->fChild=newTree(s[k]); x=x->fChild;}
                strcpy(x->s,s);
                x->num++;

                if (y!=NULL) z->rCousin=y;
                break;
            }

            while (y!=NULL)
            {
                if (y->c==s[i]) {x=y;break;}
                if (y->c<s[i]) x=y;
                y=y->rCousin;
            }
            if (y==NULL) //按非长子树插入,注意调整儿子关系
            {
                triTree z=newTree(s[i]);
                z->rCousin=x->rCousin;
                x->rCousin=z;
                x=z;

                int k;
                for (k=i+1;k<len;k++){x->fChild=newTree(s[k]);x=x->fChild;}
                strcpy(x->s,s);
                x->num++;
                break;
            }
        }
        if (i==len) x->num++; //重复字符串
    }
}

void print(triTree t, long int total) //先序遍历整个Trie树,字典序输出所有字符串统计
{
    if (t->num>0) printf("%s %.4f\n", t->s, 100.0*t->num/total);
    if (t->fChild!=NULL) print(t->fChild,total);
    if (t->rCousin!=NULL) print(t->rCousin,total);
}

int main()
{
    triTree t=newTree('0');
    long int total=0;
    setTree(t,&total);
    print(t,total);
    return 0;
}

发布了44 篇原创文章 · 获赞 9 · 访问量 4万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章