hdu 5536 01字典樹的刪減

Chip Factory
Time Limit: 18000/9000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3409 Accepted Submission(s): 1494

Problem Description
John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:
maxi,j,k(si+sj)⊕sk
which i,j,k are three different integers between 1 and n. And ⊕ is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?

Input
The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,..,sn, separated with single space, indicating serial number of each chip.

1≤T≤1000
3≤n≤1000
0≤si≤109
There are at most 10 testcases with n>100

Output
For each test case, please output an integer indicating the checksum number in a line.

Sample Input
2
3
1 2 3
3
100 200 300

Sample Output
6
400

Source
2015ACM/ICPC亞洲區長春站-重現賽(感謝東北師大)

給你n個數,找出i,j,k滿足 (ai+aj) ^ak最大
枚舉i j即可
進行增加刪減即可

#include <bits/stdc++.h>
using namespace std;

const int N = 101000;
const int BB = 32;

struct node
{
    int nxt[2],val;
}T[N*BB+1];

int sz;
int a[N+10];
void insert(int d,int val)
{
    int p=0;
    for(int i=31;i>=0;i--)
    {
        int dd=(d>>i)&1;
        if(!T[p].nxt[dd]) T[p].nxt[dd]=++sz;
        p=T[p].nxt[dd];
        T[p].val+=val;
    }
}

int ask(int x)
{
    int ans=0;
    int p=0;
    for(int i=31;i>=0;i--)
    {
        int dd=(x>>i)&1;
        if(T[T[p].nxt[1-dd]].val>0) p=T[p].nxt[1-dd],ans|=(1<<i);
        else  if(T[T[p].nxt[dd]].val>0) p=T[p].nxt[dd];
        else break;
    }
    return ans;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        sz=0;
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            insert(a[i],1);
        }
        int maxx=0;
        for(int i=1;i<=n;i++)
        {
            insert(a[i],-1);
            for(int j=i+1;j<=n;j++)
            {
                insert(a[j],-1);
                int res=a[i]+a[j];
                insert(a[j],1);
                maxx=max(maxx,ask(res) );
                cout<<maxx<<endl;
            }
            insert(a[i],1);
        }
        printf("%d\n",maxx );
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章