POJ1149

PIGS
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17531   Accepted: 7947

Description

Mirko works on a pig farm that consists of M locked pig-houses and Mirko can't unlock any pighouse because he doesn't have the keys. Customers come to the farm one after another. Each of them has keys to some pig-houses and wants to buy a certain number of pigs. 
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold. 
More precisely, the procedure is as following: the customer arrives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses. 
An unlimited number of pigs can be placed in every pig-house. 
Write a program that will find the maximum number of pigs that he can sell on that day.

Input

The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N. 
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000. 
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line): 
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.

Output

The first and only line of the output should contain the number of sold pigs.

Sample Input

3 3
3 1 10
2 1 2 2
2 1 3 3
1 2 6

Sample Output

7


合併點 + 最大流

題目大意如下:

給出M個豬圈,一開始每個豬圈有若干只豬,豬圈是上鎖的。依次有N個顧客,他們分別有某些豬圈的鑰匙,且最多購買若干頭豬,他們會暫時打開豬圈,此時可以任意移動打開豬圈裏的豬,問最多可以賣出去多少頭豬?

很容易地我們可以得出以下網絡:



但是該網絡至少擁有M ^ 2個點,可能會超時,我們考慮用如下規律將網絡簡化:


於是可以得到下面的網絡:



總結出我們按照以下規則構圖:




該網絡的最大流,即本題的答案。


代碼如下:

/* 
* @Author: duyixian
* @Date:   2015-04-21 11:43:49
* @Last Modified by:   duyixian
* @Last Modified time: 2015-04-21 16:02:26
*/

#include "cstdio"
#include "cstdlib"
#include "iostream"
#include "algorithm"
#include "queue"
#include "cstring"

using namespace std;

#define MAX_SIZE 1005
#define INF 0x3F3F3F3F

int Map[MAX_SIZE][MAX_SIZE], Before[MAX_SIZE], Begin[MAX_SIZE], Distance[MAX_SIZE];
int N, M, S, T;

bool BFS()
{
	memset(Distance, 0, sizeof(Distance));
	Distance[S] = 1;
	queue<int> Queue;
	Queue.push(S);
	while(!Queue.empty())
	{
		int Now = Queue.front();
		Queue.pop();
		for(int i = S; i <= T; ++i)
			if(!Distance[i] && Map[Now][i])
			{
				Distance[i] = Distance[Now] + 1;
				Queue.push(i);
			}
	}
	return Distance[T];
}

int DFS(int Now, int In)
{
	if(Now == T)
		return In;
	int Rest = In;
	for(int i = S; i <= T; ++i)
		if(Map[Now][i] && Distance[i] == Distance[Now] + 1)
		{
			int Increment;
			Increment = DFS(i, min(Rest, Map[Now][i]));
			Rest -= Increment;
			Map[Now][i] -= Increment;
			Map[i][Now] += Increment;
			if(!Rest)
				return In;
		}
	if(Rest == In)
		Distance[Now] = 0;
	return In - Rest;
}

int Max_Flow()
{
	int Ans = 0;
	while(BFS())
	{
		Ans += DFS(S, INF);
	}
	return Ans;
}

int main()
{
	freopen("input.txt", "r", stdin);
	freopen("output.txt", "w",stdout);
	cin >> M >> N;
	S = 0;
	T = N + 1;
	for(int i = 1; i <= M; ++i)
		scanf("%d", &Begin[i]);
	for(int i = 1; i <= N; ++i)
	{
		int temp, temp1;
		scanf("%d", &temp);
		for(int j = 1; j <= temp; ++j)
		{
			scanf("%d", &temp1);
			if(Before[temp1] == S)
			{
				Map[S][i] += Begin[temp1];
				Before[temp1] = i;
			}
			else
			{
				Map[Before[temp1]][i] = INF;
				Before[temp1] = i;
			}
		}
		scanf("%d", &temp);
		Map[i][T] = temp;
	}
	cout << Max_Flow() << endl;
	fclose(stdout);
	fclose(stdin);
	return 0;
}
引用資料:

http://wenku.baidu.com/view/0ad00abec77da26925c5b01c.html

發佈了43 篇原創文章 · 獲贊 6 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章