POJ3281

Dining
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10359   Accepted: 4764

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: NF, and D 
Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.


拆點 + 最大流


題目大意爲:

給出N頭奶牛,F種食物,D種飲料,牛喜歡不同的食物和飲料,每種食物和飲料只能用一次,求最多有多少牛可以同時享受食物和飲料。

考慮到牛,食物,飲料均只能使用一次,我們顯然可以想到最大流。

將S與食物連邊,容量爲1;將飲料與T連邊,容量爲1;將沒個牛拆分成兩個點並連邊,邊權爲1;將牛喜歡的食物與左點連邊,容量爲1;將右點與喜歡的飲料連邊,容量爲1。

該網絡最大流即爲答案。

代碼如下:


/* 
* @Author: duyixian
* @Date:   2015-04-21 08:59:50
* @Last Modified by:   duyixian
* @Last Modified time: 2015-04-21 09:38:32
*/

#include "cstdio"
#include "cstdlib"
#include "iostream"
#include "algorithm"
#include "queue"
#include "cstring"

using namespace std;

#define MAX_SIZE 505
#define INF 0x3F3F3F3F

struct Edge
{
	int To, C, Next;
}Edges[MAX_SIZE * MAX_SIZE];

int Front[MAX_SIZE], Distance[MAX_SIZE];
int Total = 1, N, F, D, S, T;

inline void Add_Edge(int From, int To, int C)
{
	++Total;
	Edges[Total].To = To;
	Edges[Total].C = C;
	Edges[Total].Next = Front[From];
	Front[From] = Total;
}

inline void Add_Edges(int From, int To, int C)
{
	Add_Edge(From, To, C);
	Add_Edge(To, From, 0);
}

inline bool BFS()
{
	memset(Distance, 0, sizeof(Distance));
	Distance[S] = 1;
	queue<int> Queue;
	Queue.push(S);
	while(!Queue.empty())
	{
		int Now = Queue.front();
		Queue.pop();
		for(int temp = Front[Now]; temp; temp = Edges[temp].Next)
		{
			if(Edges[temp].C && !Distance[Edges[temp].To])
			{
				Distance[Edges[temp].To] = Distance[Now] + 1;
				Queue.push(Edges[temp].To);
			}
		}
	}
	return Distance[T];
}

int DFS(int Now, int In)
{
	if(Now == T)
		return In;
	int Rest = In;
	for(int temp = Front[Now]; temp; temp = Edges[temp].Next)
	{
		if(Edges[temp].C && Distance[Edges[temp].To] == Distance[Now] + 1)
		{
			int Increment;
			Increment = DFS(Edges[temp].To, min(Edges[temp].C, Rest));
			Rest -= Increment;
			Edges[temp].C -= Increment;
			Edges[temp ^ 1].C += Increment;
			if(!Rest)
				return In;
		}
	}
	if(Rest == In)
		Distance[Now] = 0;
	return In - Rest;
}

int Max_Flow()
{
	int Ans = 0;
	while(BFS())
	{
		Ans += DFS(S, INF);
	}
	return Ans;
}

int main()
{
	freopen("input.txt", "r", stdin);
	freopen("output.txt", "w",stdout);
	cin >> N >> F >> D;
	S = 0;
	T = 2 * N + F + D + 1;
	for(int i = 1; i <= N; ++i)
		Add_Edges(F + i, F + N + i, 1);
	for(int i = 1; i <= F; ++i)
		Add_Edges(S, i, 1);
	for(int i = 1; i <= D; ++i)
		Add_Edges(F + 2 * N + i, T, 1);
	int temp1, temp2, temp;
	for(int i = 1; i <= N; ++i)
	{
		scanf("%d%d", &temp1, &temp2);
		for(int j = 1; j <= temp1; ++j)
		{
			scanf("%d", &temp);
			Add_Edges(temp, F + i, 1);
		}
		for(int j = 1; j <= temp2; ++j)
		{
			scanf("%d", &temp);
			Add_Edges(F + N + i, F + 2 * N + temp, 1);
		}
	}
	cout << Max_Flow() << endl;
	fclose(stdout);
	fclose(stdin);
	return 0;
}


發佈了43 篇原創文章 · 獲贊 6 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章