最長上升子序列



http://acm.hdu.edu.cn/showproblem.php?pid=1087

最長上升子序列


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
4 10 3
 


#include<iostream>
using namespace std;
int main()
{
	long long a[1009],f[1009],s[1009],n;
	while(cin>>n)
	{
		if(n==0)
			break;
		for(int i=1;i<=n;i++)
		{
			cin>>a[i];
		}
		f[1]=a[1];
		s[1]=1;
		for(int i=2;i<=n;i++)
		{
			f[i]=a[i];
			for(int j=1;j<i;j++)
			{
				if(a[i]>a[j])
				{
					if(f[j]+a[i]>f[i])
					{
						f[i]=f[j]+a[i];//子序列,每個以i結尾最大的數
					}
				}
			}
		}
		long long max=-1;
		for(int i=1;i<=n;i++)
		{
			if(max<f[i])
				max=f[i];
		}
		cout<<max<<endl;
	}
}


	


發佈了65 篇原創文章 · 獲贊 3 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章