Zball in Tina Town-----(BestCoder Round #51 (div.2))

Zball in Tina Town

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)


Problem Description
Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 1 time as large as its original size. On the second day,it will become 2 times as large as the size on the first day. On the n-th day,it will become n times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.
 

Input
The first line of input contains an integer T, representing the number of cases.

The following T lines, each line contains an integer n, according to the description.
T105,2n109
 

Output
For each test case, output an integer representing the answer.
 

Sample Input
2 3 10
 

Sample Output
2 0
 

Source


分析:找規律,這題就是求 (n-1)!modn(n−1)!  mod  n。如果nn爲合數,顯然答案爲0.如果nn爲素數,那麼由威爾遜定理可得答案爲 n-1n−1。所以就在於快速判斷一個數是否爲素數。


CODE:

#include <iostream>
#include <cstdio>
#include <string.h>
#include <cmath>
using namespace std;

int xindalamu(int a)
{
    if(a%2==0) return 0;

    int aa=(a-1)>>1;
    int half=(int)sqrt(aa/2.0);

    for(int i=1;i<=half;i++)
    {
        if((aa-i)%(2*i+1)==0) return 0;
    }

    return 1;
}

int main()
{
    int t; cin>>t;
    int a[5]={0,0,1,2,2};
    while(t--){
        int n;
        cin>>n;
        if(n<5){
            printf("%d\n",a[n]);
            continue;
        }
        if(xindalamu(n))
            printf("%d\n",n-1);
        else
            printf("0\n");
    }
}


發佈了120 篇原創文章 · 獲贊 14 · 訪問量 20萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章